Robot Control Problems when connection problems

The other day my team and I were competing at a local qualifying regional we finished the qualifying rounds with a win loss record of 6-2. Both of the matches we lost we experienced the same problem where shortly after it has been switched into driver control the robot would stop, becoming completely unresponsive and just continue to run two of our motors. The VEX official told us it seemed as though it could be a programming error and to trying just loading drive code onto the robot and run no autonomous. We did this for the quarter finals and in the first match (of quarter finals) we had a problem that occurred at our previous tournament where when the robot we enabled into driver mode we had no control what so ever. But it couldn’t be a problem with the code because if we reset the robot and tried to drive without being plugged into the competition switch everything functioned perfectly.

I am wondering if anyone else has experience these problems and how might I be able to fix this? Because I don’t think it can be a programming error if we made a new program that just contained driver code using the basic built in driver functions.

Do you think the Cortex is probably just faulty? Should we just change the cortex?

RobolovR :slight_smile:

We need to know more details before we can give an opinion, especially important at the moment with recent hardware/firmware issues.

Please read this post and try and give us some details, pay special attention to firmware versions and programming environment (EasyC or ROBOTC).

Me and my team were experiencing the same problem at our school event. Before you download anything, make sure that you hear the “CLICK” of the competition cord. If it doesn’t click,then your robot will probably not move.
If you do hear a click and still nothing happens, you might want to switch out the keys. We did that and it worked the rest of the competition. Or turn off all controllers AND robot, then turn it back on.