Robot debugging

Hi,

I’m newer to robotics and I just finished building my first robot and programming it. Obviously the first test was a failure, but I don’t know what the problem is. The motors didn’t seem to run. I can hear one motor running but the other 3 are not running.

Things I tried:

  • fiddled with the code(it should be correct)
  • tried charging the batteries
  • turning the RPM of the motors higher

Is there any other reason this could be happening? Or is it just that the motors are dead. I am using 4 VEX 269 motors.

Note: this is not for competition this is a personal kit

You said that you are running a code, do they work in driver control? Test this and also try just plugging the motors into the brain independently, and see if they run with no resistance. If they do, try placing your finger over the turning circle, and see if you are able to stop them from turning with one finger. If so, they need to be replaced.

As you are using 269 motors I am going to assume you are using Cortex or possibly the older PIC microcontroller.
If you are using Cortex, what ports do you have the motors plugged into? The reason for asking this is that ports 1 and 10 have integrated H bridge motor drivers and so give you a variable voltage output with which to drive the motors. Ports 2 through 9 have a supply rail and a PWM output. To drive a motor from these, you need to use the Motor Controller 29.

Posting your code would also help (use the code tags when posting code so that it formats nicely)

3 Likes