Robot isn't moving!

So uh recently my robot stopped working. The brain and the remote controller will connect. But after they connect, the robot won’t do anything else. When I move the joysticks the robot just sits there. When I press any button the robot doesn’t respond. I’ve tried turning it off and on but nothing happens. I’ve tried using a USB cable and connecting it from controller to brain. It doesn’t work. I’ve tried rebinding the vex nets. I’ve even tried connect USB cable to brain and computer to redownload the program and it still doesn’t work. I also unplugged I2C in desperation. It didn’t work. Someone help me please. This happened while I was running autonomous.

Is it programmed? If yes then is the program downloaded?

Are there any signs of life in your program, like an LCD responding, or other motors, or something else? This means that your program was downloaded successfully. Look at PTC trips, Low Battery, or broken motors.
If you know the problem is with software, isolate it. After commenting out several lines, you should know exactly what your error’s coming from.
Make sure that you are connected correctly, by sending data to ROBOTC’s debug stream. Additionally, try turning off any 2.4Ghz wifi routers near you; these have a history of interfering with VEXNet
If you cannot find the error in your code, post it here, someone will most likely be able to find it

Do you think a wifi airport would have the same affect upon the VEXNet?

image

14 Likes