Robot led is red

(Vex V4) In our robot, we are using stack lift system for lift cubes. Everything is ok but when i click the button that lift system, robot led on microcontroller and remote controller are being red. The system can lift easily even robot led is red. I looked troubleshooting, but it isnt help. Robot was working yesterday, and there isnt any problem, but today when i try system, robot led getting red

how hard r u pushing the bot and how long do u continuously run it

Wait doesn’t the the robot led signify that the controller is connected to the robot? So if it is red then doesn’t that mean that the vexnet got disconnected. Correct me if I’m wrong.

vexnet has its own led light the 3rd down

1 Like

Oh nevermind the robot light represents the battery life on the robot. So if the light is red then the robot battery is going to die soon and needs to be charged

We are using reducer, system lift cubes easily but when its starting to lift, robot leds getting red

or i believe it could be u r pushing the bot too hard for too long that the motor burns out and if motor burns out then what does the bot have to run off of

I thing i explain wrongly. All the leds on robot is green but robot led is red

It could be but i try them without connect system. Nothing change

Only robot led getting red

have you tried to change the controller and cortex?

I change Motor controller only. But it disnt change

İf it pushing bot too hard, robot cant work. But yesterday, it was working

the problem that you are having is that whenever you are moving a certain part on the robot the controller disconnects. This is not a problem with a motor controller. Motor controllers control motors, but this problem is related to the vexnets, driver controller, and cortex. About 3 years ago my team had a similar problem and by changing our cortex and vexnets we fixed that problem. Do you have any pictures of the robot so we can further figure out why this is happening? Or a video of this incident?

1 Like

I dont understand, robot was working yesterday. But today…

So yesterday the robot wouldn’t disconnect, but now it is? When I had the V4 system, it was never reliable enough when I used it. It would stop working suddenly, problems would occur like yours often. I would always carry extra electronics like extra controllers, cotrexes, and motors. I don’t know why all of a sudden it is disconnecting but you should try these suggestions that are mentioned above and let us know if that helped or worked.


I will take a video and upload it tomorrow.

1 Like
1 Like

I mean, you seem to still have full control of the robot. Maybe the led is just malfunctioning.

We changed all system. The problem has been solved

1 Like