Robot moves forward on its own in remote control mode...

The robot has begun to move forward on its own (not in program mode). This happens when we are using the remote and are in starting position, getting ready to remote control move the robot. The robot keeps inching forward on it’s own when we have not even touched the remote. We have to fight with the robot to control it and make it go where we want it to go. What it going on? How can we fix this? We have tried turning off the controller and brain completely to reset it. That did not work.

Please advise.

This may be caused by the joysticks on your remote control not returning all the way to center. My VRC teams run into this all the time and usually put a deadband in their code so that the robot doesn’t move until the joystick on the remote control is over (or under) a certain value.

Have you tried the Controller Calibration steps yet? It wasn’t mentioned in your description. It can fix your problem. I have also had the controller joysticks stick a little…and usually let them go so they spring back to center.

We do the same cause kids before the start of the match tend to put the fingers on the controller and the robot may move before the match start.

task main()
int threshold = 10; //* Program will ignore movement instruction if value returned by the controller is less than this number. *//

if(getJoystickValue(ChC) > threshold || getJoystickValue(ChC) < -threshold)



Hope this gives you an idea.

Hi Mrs. B,
We’re sorry you’re having this difficulty. As others above have said, calibrating your controller may be able to solve your problem. Here’s a video showing how to calibrate the controller: . All of our video resources can also be downloaded, here: