ROBOTC 2.30 Firmware Errors.

Just recently we have tried (once again) to upgrade our robot to the 2.30 version of ROBOTC. Well, we have run into problems trying to download the firmware (once again).

Pretty much, we have installed ROBOTC for Cortex and PIC 2.30, and when trying to download the Master Code, we get an error telling us that the file is either corrupt or could not be found. We have tried completely uninstalling and reinstalling ROBOTC 2.30, browsing for the Master Code file and opening it that way, selecting the USB port from the detailed preferences and numerous other things, and we still get the same problem. This is the second time we have tried updating, the last time being close to the release of ROBOTC 2.30.

I haven’t heard of anyone else having this problem, so I’m assuming it can be fixed, and is just something I am doing wrong, although I don’t understand what that is/could be at the moment.

Thank you in advance for your help,

It has as of now been nearly two weeks since I posted this, I would like to have a reply sometime soon… I guess I will try the ROBOTC website, as well…


Hi Jordan,

The problem may be that one of the ROBOTC registry keys has gotten corrupt. One thing that you could try, if this is the case:

In Windows, go to Run, and type “regedit” to open your registry editor.
Navigate to HKEY_CURRENT_USER - Software - Robotics Academy
Delete any of the ROBOTC folders in that directory
When you restart ROBOTC, it will re-create these registry settings, and hopefully correct your directory problem.

Let me know if that helps

Awesome thank you so much! I did what you said and it’s working great, I’m loving the faster downloading times for the firmware on the joysticks, (at least from what I can tell it’s faster) and I loved how fast my CORTEX was paired to my remotes, not sure if that was just me either but I noticed an incredible speed difference.

Thanks again!