RobotC 3.08.Joystick Problem

Upgraded to RobotC 3.08 and none of my joysticks work.

Normally, I can power through these problems but so far no luck.

Windows 7 , 64 big Toshiba Satellite
Tried with two different Joysticks.
Debug shows no response to inputs.
Looks like the Joystick in not being recognized.

Downloaded new firmware with and without clean reset on Joy and cortex.
Downloaded both automatically and manually.
Only tried with one cortex.
Reinstalled Win 7 64 bit Vex Joystick drivers. no luck

Cortex runs programs and debug works ok for programtic inputs.

Any ideas??

Hi Vamfun,

Did you go through the process of re-pairing the joystick and cortex:

Also make sure that the Robot > VEX Cortex Communication Mode is set to “VEXnet or USB”.

OK, that did it. I knew it was something silly. In all my years of using RobotC I have never run into this.

Was it always like this ? I am using a USB tether to the joy stick and am downloading through the orange cable and am not using vexnet. So why inhibit the JOY stick?

It’s been like this since shortly after the Cortex came out, but was not there with the PIC.

It’s in place for users who are not using the Joystick at all. Depending on what version of the Master Firmware is in place, if the Cortex is in VEXnet or USB mode, it will wait for either a VEXnet or USB connection before running user code. In USB only mode, the Cortex only determines if there is a USB connection before running user code, allowing users without joysticks to run autonomous code.

Is there not a human factors problem here or do I have a misconception with the meaning of VEXnet? To me, the word VEXnet is always associated with the VEXnet wireless key. Apparently, it must be associated with the joystick.
My configuration doesn’t use the VEXnet key but it does use the joystick. This is why the wording of the download method can be misconstrued.

Perhaps the “USB only” should be changed to USB(no joystick) or just NO JOYSTICK

Thanks for the feedback. I definitely see your point.

When choosing what to call the menu items we actually did consider using the words “joystick vs. no joystick”, but there’s another common use case, where users are taking advantage of the VEXnet wireless connection/joysticks to do wireless, autonomous programming. The “joysticks / no joysticks” option was confusing because they weren’t actually using the joystick values, but needed the hardware for communication.

The current menu items are a result of teachers who are using ROBOTC with the Cortex in their classrooms. Perhaps it’s time to re-survey. :slight_smile:

Ok… I now have another 3.08 .5v micro controller joystick problem.

We built a protobot with a new .5v controller. The xmitter worked with the code that came preloaded with the controller.

We updated the firmware that came with 3.08 and now the joystick will not work. It appears that it is not recognized. We tried both 75mh xmitter and tethered linking. Is there another trick I am missing? We can command the robot using autonomous code ok.

We redownloaded the default firmware from Vex site and the xmitter worked again.

So we have a working robot with default code but cannot modify it and have it work with the xmitter.

We are running master version 10 and robotC 9.12.

When you download the ROBOTC firmware, it wipes out the default functionality to make room for your own code. Check out the Radio Control section of Teaching ROBOTC for VEX for tutorials on how to do so:

Ok… to save others the search in the link:

The answer is:

bIfiAutonomousMode= false;

This initializes the user mode so the joystick works. Not sure we always had to do this.