RobotC communication error

Ok. So recently I started getting this error in RobotC that there isn’t a communication link available(check the attached file). I’ll get this error whenever I try to download the code or update firmware on the cortex or the joystick.
So far I’ve tried:
updating the firmware on both cortex and joystick with both being on and off,
Changing the comm port,
Re-connecting the cortex and joystick(by plugging the A-A usb cable into them both and turning them both on for about 20 seconds),
Plugging each vexnet key into my laptop and updating them both(It wouldn’t recognize my vexnet keys either if that tells you anything) but no matter what I try I always get one of the two attached errors.
I’m wondering if my computer has something going on with the usb ports(I’ve tried 2 of them) or if it’s just something going on with robotC(It started happening before the recent update though if that helps any).

Thanks in advance for any help :slight_smile:
C error1 (2).png
C error2.png

Ok so a quick update on the issue: I found out that when I plug something (cortex or joystick) into my laptop it is getting recognized but they have a driver error. So I tried to update the drivers (with internet connected) and I keep getting an error with that. I also downloaded the driver thing from vex’s website and followed the instructions on it to no avail.

Never seen the steps that you’ve taken not work in fixing the problem, this one sounds weird for sure maybe @jpearman or @tabor473 have an answer or have seen this happen? My way unofficial advice for a next step of what I would do is secure your code and then uninstall/redownload robotc with a complete reinstall. That would be the most sure fire way to resey the drivers. If you have a second joystick/cortex you might want to see if the same error pops up on a different set.

Thanks for the suggestion!!! However, I just got done trying a fresh install and it still has the same problem. Later today I plan on trying out a different remote and seeing if that works.

You second image says master comms is working, that usually means you need to re-download the ROBOTC VM firmware. Steps I would take.

Look in the device manager, what do you see under Ports, perhaps grab a screen shot of that. You need to be able to see the cortex here or nothing else will work.

If the cortex (or programming cable) shows ok in device manager, do a software inspection in ROBOTC and see what that shows, if you can see the cortex firmware version (hopefully 4.25) but nothing for ROBOTC you need to download ROBOTC firmware again manually.

ok @jpearman, so When I plugged the cortex (or the joystick) into my laptop they both showed up in device manager but they had a little exclamation sign next to their name that if I’m right ?indicates a problem with the driver? So I double clicked on it and chose to update the driver but no matter what I try to install on it (I even downloaded a fresh install of the drivers from vex’s website) or if I let it try to auto install something I always get an error(that’s attached as the second picture) when trying it with both the joystick and the cortex.
I also tried the software inspection and it says that there isn’t a communication link available to the device (i tried doing it with both the cortex and the joystick plugged in and both brought up the same error).

Thank you for the help so far! :slight_smile:

Well, it’s definitely a driver problem and that’s always hard to debug. Which version of windows is that ? I would start by removing any existing driver for that device and re-installing using the appropriate driver from C:\Program Files (x86)\Robomatter Inc\ROBOTC Development Environment 4.X\Drivers either VEXCortex32 or VEXCortex64 depending on OS. I would install with admin priviledges just to be sure. Until the cortex shows correctly in the device manager as a Vex Robotics Comm port ROBOTC, or any other IDE, will not be able to communicate with it.

You may be able to uninstall old drivers by going to View -> Show Hidden Devices in Device Manager.

@jpearman I have Windows 10.

I tried all these and so far I just keep getting the same errors.

Thank you all for the help though! I may try and play around with it some more and if I can’t get it to work I think I’m just going to send it in :slight_smile:

Ok, windows 10, I could not tell if it was 8 or 10.

Do other devices work on those USB ports? If so, it’s unlikely to be your PC.
Can you get me the exact build of Win10, look in settings, see attachment.
You said it used to work, when did it stop? Had you just updated ROBOTC or perhaps had windows done an update ?


Thank you sooo much to everyone who helped me with this!!! @jpearman’s last post got me thinking and after some investigating I found out that Windows had installed a couple security updates around the time this issue started and after I uninstalled both of them and played around with the cortex and joystick firmware everything started working again!!!
Thank you all!!!

Can you tell me what they were so we can investigate further ?

One of my concerns is that Windows 10 has changed driver signing requirements, but these requirements only kick in under certain conditions, a clean install of build 1607 or later, secure boot on, driver signed after July 2015, perhaps other things as well. We should be ok with these old cortex drivers as they were signed a long time ago, I’m just trying to figure out if a recent change to windows 10 has broken something we are not aware of.

and you said “played around with cortex firmware” was that after the drivers loaded correctly ?

I tried to check for updates so I could see what the updates were but my internet was being screwy(unless there’s a way to see previously un-installed updates that I’m not aware of?) :confused:

I hadn’t updated the firmware after the robotC update that recently came out because I started having that communication error before I could get around to it.

I believe (if I remember right) that I was programming as the windows update was downloading (since it’s so great at asking my permission before updating :stuck_out_tongue: ) so I’m not sure if that could have caused it or not? I also think there were a few updates that failed to install after the two security updates so I’m not sure if that may have kept the problem from happening if they had installed.

Ok, no problem. It was probably just “one of those things” that happened to you, sometimes computers just don’t work and we don’t know why. I did try the drivers under the latest windows 10 insider preview and everything was working ok, we will wait and see if others have issues in the future.

I’m relieved to see someone with qualifications and skabilities (skills + abilities) voice this sentiment.