RobotC failed system check

Since I’ve updated RobotC to 4.56 on one system (Win10 tablet that we keep shared at school), it complains on every startup that “Security Identifies Failed System Check - Purging all licenses.”.
It displays a dialog like this 4 times on startup, then works OK.
Now, that only happens when the device is offline. When connected to internet, no problem, no message.
As for the licenses, I only have “RobotC for VEX Robotics” active. This particular device used to have a 365-day VirtualWorlds license, but that expired already.
If I start if offline, error messages and the license dialog only shows the non-expiring VEX license.
If I start it online, no error message and the license mentions both the infinite VEC and the expired RVW license - which I have no way of removing.

I have tried reinstalling (3 times)
I have tried purging registry between uninstall and install.
But no change and I still see this behavior.

Any idea what could be wrong and how to fix that? This error dialog would certainly throw off the students trying to use it…