ROBOTC Firmware Download Glitch


We are new to VEX IQ and also the ROBOTC programming software, and we need some help. Our ROBOTC has not been working lately. In the beginning, it worked perfectly fine on our Stretch, but once we downloaded an edited program to the Stretch to replace the old one, it deleted all of the firmware for ROBOTC from our Stretch. We tried to re-download the firmware, but that didn’t work. Whenever we click on the “Firmware Download” button, it shows the downloading pop-up for less than one second, and then the pop-up disappears. We checked the robot brain to see if it downloaded, but it didn’t. We tried it several times, but it still didn’t work. We updated the VEXos firmware, but that didn’t work either. We even restarted the computer, and still, none of it worked. Is there any resolve to this problem, or will we have to uninstall and re-install ROBOTC? Thanks for your help!

Are you trying to re-load the RobotC firmware or your program you wrote? They are two different things and two different buttons on the RobotC console. Are you using Graphical RobotC? The “download to robot” button is what you use to download your program, after you compile it.