RobotC / VEXrobotics core software problems with older laptops?

We have a number of older Dell 610 laptops running XP. We have 18 Cortex units. We’ve been having a large number of problems with programming the Cortex with the 610. The new “dance” with the new USB stack and core has rendered a number of our laptops to a state where they won’t program the Cortex any longer.

I’d hate to think that we have the only laptops and Cortex that are having problems with the new software.

Is this a common problem with older systems?

Is there some rituals that will allow us to successfully load the new USB/Core stacks?

Do you mean loading the new master firmware? (3.16 as far as I know) or do you mean communicating with the cortex after loading the firmware? Are you a RobotC or EasyC team? Have you loaded the new USB driver?

We did all the cortex updates from one PC at the same time, mixed versions was a concern for us so we did them all at once after beta testing on one unit. Mostly I use a Mac for updates running Win 7 under parallels, but I just configured an old laptop for one of our student programmers which dates from 2003 (an old Sony Vaio). It’s running XP SP3, we have no problems with that.

I’ve developed from an old HP/Compaq nc6120, with a 1.4ghz Centrino, 1gb RAM (upgraded), an XP SP3. It’s from 2005. My school was throwing them away, so I grabbed 4 for robotics stuff.

No issues. I’ve worked with a total of 5 Cortexes and 6 Joysticks, upgraded them all from 2.x to 3.17 master, and have used easyC and robotC.

I have a problem where my laptop is running RobotC 2.32, but others are using RobotC 3.0 or later - when the cortex is firmwared to 3.0, it won’t accept any downloads from the 2.32 version. What I end up doing is manually putting the cortex into bootload mode by holding the config button while plugging the usb cable into the cortex (with the other end already plugged into the laptop). This seems to reset it and allows me to download code to the cortex from 2.32 again.

The old firmware setup the USB as a Human Interface Device (HID). The new firmware set the cortex to be a communications device (CDC). They are not that compatible but RobotC V3.XX has a preference to set the communications type.

https://vexforum.com/attachment.php?attachmentid=4924&stc=1&d=1322963152

When you put the cortex into bootload mode it reverts to the old HID USB communications, thats what is burnt into the bootloader code.

Why don’t you upgrade? Our 2.xx licenses worked just fine with V3.xx.
robotC_pref.jpg

It’s not letting me deactivate the license, so I’m just going to keep using 2.xx - my laptop won’t be used for competition programming, just testing the odd bit of code so it’s not too much of a deal; we have others who are programming more often which is why they’re all on 3.xx

Oh well, I thought it might be a similar problem to Foster but it sounds like mine is an easier fix than his.