RobotC VM not started

While running a VexIQ programming intro class for teams around our school district, two of the teams present run into a strange issue - RobotC was failing to upload their (mostly) trivial programs.
Like, they had it working half of the session, but it started consistently failing later that day (with no change in the setup, at least no intentional).
Now, the actual serial link was perfectly working, firmware upload worked well and did the full upload (I’ve had the messages window opened and seen the messages exchanged).
But uploading program? No dice - RobotC did three attempts (serial messages, unfortunately I don’t have the log) with no reply from the brain, while subsequent repeated RobotC firmware upload still worked. I went as far as getting one of the brains into the DFU mode, reuploading the master firmware, uploading the RobotC firmware, but still no answer for uploading user programs.

I took one of the robots home for further investigation and tried other tools - file management didn’t work either, but SW inspection did, to some extent - and among the things it reported was that “RobotC VM isn’t running”. At that point, it struck me, I reached for the brain, in the selected the “Autonomous programs” menu entry and, magic, program upload started working.

So it seems that the issue the whole time was that RobotC VM wasn’t started initially, so it wasn’t picking up its custom serial messages from the lower OS. Is that some kind of recent change in behavior?
Looks like a bug to me, certainly something 4-graders shouldn’t need to worry about.

VexOS: 2.0.2
RobotC: 4.56
All motors/sensors updated to the latest firmware.

You may want to put this thread here:

Or, better yet, under the robotC official answers at vex