Rpi4 3.5mm jack audio

Is it possible to get the game audio out of the 3.5mm jack of a Rpi4 while a HDMI device with audio is also connected? I don’t necessarily need output over HDMI, but it wouldn’t hurt to have both. The 3.5mm jack works fine with no display connected, but is disabled when the HDMI display is active.

This is from the event partner section. I use it on all my monitors and works great. I actually don’t know if it also gives audio to the hdmi as they are all on hdmi / dvi adapters and would lose any audio they have. The monitors I use have a separate audio jack.

All credit to @Dave_Flowerday, but I couldn’t link it directly because it’s in the EP section.

Dave_Flowerday

1

Feb '19

I’ve heard this can be common. I don’t have any such monitors myself to test with though.

If you want, you can try to override the Pi’s HDMI audio detection. You have to put the Pi SD card into a PC and then edit the ‘config.txt’ file that is in the folder from the SD card. At the bottom of the file, add this line:

hdmi_ignore_edid_audio=1

In theory that should cause the Pi to ignore the HDMI audio detection and always use the analog headphone jack output.

5 Likes

Perfect, thanks! No amount of google-fu had turned up that parameter for me.

And let me know if/how it works. I just saw this is for a rpi4 and I’ve only done this with a 3.

You can also use something like this.

2 Likes

On the latest Raspberry Pi image, you should be able to access
http://[pi ip address]/audio
in your browser to control the audio output as well.

8 Likes

Edit: One or both of the solutions worked. Realized the sound mixer wasn’t turned on when I was testing. Thanks for the tips!

Unfortunately neither of those solutions is getting any audio out of the 3.5mm jack. :confused:

Possibly a quirk of the pi4?

Should this still work? I tried it on RPi and it gave a not found error. The issue I am having right now is that I have a field monitor connected with an HDMI to VGA adapter cable. If I boot the pi with the video cable plugged in, it will redirect the audio into the HDMI output, so I can’t get audio out of the 3.5 mm jack. If I boot the Pi without the video plugged in, I can get audio out of the 3.5 mm jack, but when I plug the video back in, I get an improper aspect ratio on the monitor. Normally to fix that I would reboot the Pi with the video plugged in, but that would be back to where I started with audio.

2 Likes

It worked for me at my tournament in mid-December

1 Like

Are you sure you’re running the most recent base image? This is part of the OS image, not the TM software which gets updated from within TM.

I am not sure of that. I was using equipment that was not mine, and I don’t know what version of the image the Pi’s were built with. I will try it with some that I know were recently imaged this week, but it is likely that the ones I were using were just running an older image. Thanks.

1 Like

So, I find myself without and audio again after updating the base image on my Pis. The audio settings on the web interface are set to the 3.5 jack, and I also tried putting the ignore parameter in the config file and the audio continues to only be transmitted out of the HDMI.

Any ideas to get game sounds back to the 3.5" jack?

Thanks

Not that this is a solution but my workaround for that issue has been to plug into the screens 3.5 jack which mine happen to have. Might be worth checking yours.

Unfortunately this is not an option for our setup due to the location of the devices in question. Good suggestion though.