sensor & motor not detecting

In the last week I’ve had a smart motor off a students robot and a touch led off my own demo bot stop detecting. I tried another touch led on my bot and it worked great, so I know it’s not the brain or cable. And the replacement smart motor I gave my student works fine. I also tried connecting it to the firmware update to reinstall the current firmware but it didn’t work there either. Also tried different ports with no luck.

  1. Is there a way to fix this? I tried blowing them out with some compressed air, and giving them a light tap on the desk, but nothing.
  2. Is there a way to prevent this? It’s really concerning that they seem to be dropping this quick.

Extra info: All bots updated to latest firmware in September. Batteries are fully charged. Using robot mesh to program on Ubuntu 12 machines. HELP!

Besides initial update, have you done any more updates when the robot unexpectedly asked for one?
I have seen few cases where during such an update, one device receives firmware destined for another device of a different kind.
See http://www.vexiqforum.com/forum/main-category/technical-discussion/10620-careful-firmware-updates
For the motor, I was able to revive it using a modified cable, but no success for a similar issue with gyro and TouchLED so far…

Interesting, I guess I’ll be updating one component at a time from now on! That might have been what happened to the motor, but the touch sensor went out when I was testing the robot in a field (had been working, but ran the program again and all of a sudden it threw an error).

When you shorted the red and yellow, was it shorted on the brain side, motor side, or was it like an H?

And I just want to make sure I have this right: Once you have the motor plugged in to the brain with the modded cable, the firmware update utility showed that you could update the motor. Then you update the motor with the modded cable still plugged in. Then you swap back to a normal cable after update?

Hi I3iggy,

If you are having issues with a non-responsive VEX IQ sensor, please contact VEX Technical Support at support@vex.com or by calling +1-903-453-0802 so we can help to resolve the situation.

Regards,

  • Art