So this is my second problem and I need some help with this

#1

So my second problem right now is that my motor is not working. It sound kinda weird, but we tried out our code and our claw started working fine, however, after about 10 second it started to get weaker and weaker and then it just stopped working. We charged the battery to 100%, but that still didn’t work. We also have the extra backup battery sort of thing, but that still didn’t work. I also changed the motor with a newer one, and cleaned the motor and it still doesn’t work. Please help us…

0 Likes

#2

I suspect you are triggering the internal PTC which protects the motor. This would happen if the motor was stalled for a long period of time which is common with a claw where you are driving it closed a lot to grip something.
If you wait 30 mins then it works fine again, this will certainly be the cause of the problem.

2 Likes

#3

Well if you’re using v5, then maybe you could detect when a torque threshold was reached, aka the claw is holding something. Then set the motor to hold.
I think that’s how it works, but I have primitive coding knowledge so it’s best to ask around.

0 Likes