sometimes failed to save and my projects gone-Modkit

I’m a freshman with Vex IQ robot and programing,i tried to write two projects with Modkit yesterday,and it happened several times “failed to save”,and today,when i want to continue my projects from browse,“My Cloud Projects” showing nothing,i don’t know what happened,anyone can help?

Hi Ken,

We’re sorry you’re experiencing these issues. With the cloud storage, when a project fails to save it will not be available when you log back in so that part is normal. A project can fail to save for a number of reasons including loss of internet connectivity. If you continue to have issues with the save feature please send an email to and include the google or yahoo account you use to login to Modkit so we can look into your account.

Also, if you do not want to be affected by connectivity issues, we recommend using the offline (desktop) version available in the Modkit store:



I found the problem which “My Cloud Projects” showing nothing is with the browser, because last time I used Firefox to login Modkit, today I just tried another browser (360 browser) and it worked, when I browse my cloud projects,it shows all the projects that I saved before.

So it’s that a issue with Firefox or maybe my Firefox browser version is too old?