Spooky Motors

So our robot has been working perfectly fine over the last month.
It’s has a 6 motor drive among various other things, but the drive is our main concern right now.
So, i was messing around with the autonomous and stuff. I didn’t run it, i just saved it for later. Later when i tried driving it (note, i didnt change the driver code at all), the back two motors suddenly stopped working even though they are assisted via chain to other motors.
i smell something burning.
i tested the motors in the ports of the other working motors… Ta da! it still doesn’t work.
The other 4 motors on our drive were fine, but for some reason these two have been acting up.

tldr; two motors arent working anymore and i smell something burning.

I know i’m gonna replace the motors anyways, but does anyone have an idea as to what the problem could be? (Like, is it the motor controllers, motors themselves, etc.?)

Thanks in advance :^)

When this has happened to me before, it was actually two things that ended up happening. One, the motors themselves went bad, and two, somehow they actually ended up smoking up the ports in the cortex (as you could probably guess, ports 1 and 10). I realized that the problem was probably caused by the fact that these motors were resoldered (although if I had known they were resoldered from the beginning I would never have used them), and I haven’t had any issues since.

tl;dr never use resoldered motors, as they & their cortex ports will end up going bad.

Sounds like the motors shorted internally and the motor controller driving them burned. Take off the back panel of both motors and make sure the insulation isn’t cut.