starting error easyC V2

I thought that I might be able to offer some help to tuelbox12 who posted this question on the EasyC Technical Support Q&A:

"When ever i try to start my Intelitek easyC for vex controler V2. An error pops up and says Starting Error. and easyc never opens up. is there any thing i can do? if i uninstall it can i even reinstall it?


Tuel "

I have a Dell laptop that I purchased in August 2007 which has Windows Vista. I had purchased the Windows Vista version of EasyC V2 in January of 2008 and it had worked perfectly until March (I think) when I installed some recommended Windows Vista Updates. I went to change a program so I could download it to the microcontroller and EasyC V2 wouldn’t open. I believe that I got some kind of starting error box also. After I uninstalled the updates EasyC V2 worked fine.

Serval times since then I have installed recommended updates to Windows Vista that have caused EasyC V2 and my printer software to stop working. After I uninstalled the updates everything worked fine.

I don’t know what version of Windows you have on your computer, but if it’s Vista this might be your problem. I have since stopped installing Vista updates all together. This may not be the best idea, but it keeps my VEX software and printer working.

Sorry for the long post, but I thought the information might helpful.

i have XP but that might be causing the problems

how did you tell which ones were causing the problems?

I never had XP so I don’t know if it would have the same problems as Vista or not. My old computer had Windows ME and it was too old and not worth trying to upgrade to XP so I had to buy a new one which had Vista.

I had installed a lot of updates for Vista the night before I had trouble with EasyC V2 the first time so I just looked at the dates and uninstalled the ones from that night.

From then on, I started checking EasyC V2 after I installed any updates. If it stopped working I would go back and uninstalled the updates. I did the same thing when my printer stopped working until I finally decided to stop installing any updates at all.

Did uninstalling the updates make anything else stop working like on mine if you click on one of them it says that if i uninstall them it will cause them to not function properly

Starting errors are caused by required .dll’s not being able to load upon execution. This usually caused by corruption in the registry or the windows file system. Every time we have seen this error it it caused by either a corrupt windows .dll or another application has replaced a needed system dll with a ‘special’ version.

tuelbox12,

I’m assuming that you previously had EasyC v2 working properly on your XP computer. If so, do you remember the last time it worked properly?

Whenever I run into software problems when something formerly worked but stops working, I usually do a System Restore. If you go to the Control Panel > System icon > System restore tab, there are a number of options. One is to create a Restore Point (a good idea before you undertake any major software experiment or installation), where you can return your computer to. Another is to return your computer to a previous Restore Point from an earlier date. Your computer automatically creates Restore Points, usually a couple times a week. If you have a date when Easy C was working properly, you can restore your computer to that date. You will lose all software changes made since that time, but you don’t lose data like documents or e-mails. If going back to the earlier date creates more problems than it solves, you can reverse the process and return to today’s date (if you created a Restore Point for today, before you attempted to reverse the process).

I don’t know much about the innards of computers, but every time I’ve had a major software problem, including a couple viruses that have crept in, I have always managed to get things where I wanted by going back in time.

Yolande

P.S. Sometimes I’ve had trouble doing a System Restore. This seems to be related to updates by Norton Antivirus, and there are ways of getting around this (not recommended by Norton). I used a Google search to find advice on the sequence of steps.

No, I didn’t have any problems like that. All the updates that I had were basically security or general Windows updates. One of them was a service pack for Vista and that’s the main one that caused EasyC to stop working the first time.

I got the new version installed on another xp computer but which cd code do I use? Do I use my old one?

Yes, use the CD-Key from you envelope, if it doesn’t work email: support@intelitek.com

I just assumed my problems were caused by the updates to Vista since EasyC worked before I installed them, but not after. Plus other updates since then have caused it to stop working along with my printer software.

Is there any way to tell what is actually causing the problem and to fix the cause you mentioned above. Like I said, my only solution has been to stop installing updates which probably isn’t the best idea.

If you can provide, a specific update name / program name we can look into the issue. Though, our entire support department has all of the updates installed from Microsoft and haven’t seen this issue.

or

If you can get into a Starting Error state and let us remotely connect to your computer we could take a look and see what is actually causing the failure.

I don’t remember which update caused the first problems, it was some time last spring. The most recent ones were Service Pack 1 for Windows Vista and then 3 Security Updates for Windows Vista (KB954459, KB955069, KB57097) from 11/11/2008.

There have been other updates since then, but I couldn’t find a way to copy the list of all the updates that I haven’t installed. Counting the Service Pack, there are 20 - I think. Some of them I didn’t even try installing so I don’t know if they would have caused a problem or not.

I appreciate your offer to remotely connect to my computer so you could see what is going on, but I wasn’t sure how we would do it. Would we start with the first updates that caused the problems or would it be better to just install all 20 and preceed from there? My only problem with that would be that I don’t remember which ones caused the problems with my printer.

Well if it does it again give us a call and we can have a look at whats going on.

Thanks, I will do that.

I’m encountering the same problem as the Original Poster, except EasyC never worked on this computer. I installed EasyC onto a different laptop but the message “application already running” pops up whenever we try to run the program.

Three Things…
Do you know which version of EasyC you are trying to install?
Which version of Windows are you installing on?
Did you Right-Click and “Run as an Administrator” when you did the install???

If your getting “Application Already Running” easyC is running in the background. Reboot and then try again.