Trouble Getting 2.0 Keys To Pair

When trying to get our new keys to pair the lights on the controller and robot were all red. We have updated the master code on the controller and the robot. We can drive while they are both tethered together but won’t drive with the two keys.

Any suggestions or anybody with the same problems

Thanks in advance.

Sounds a bit like this.

I was at a BEST event last weekend and tried a pair of the new keys with similar results, epic fail. I had grabbed the latest drivers from here:

and found that although my Cortex and handset were updated, the keys I had tried also needed to be updated to VEXnet Key 2.0 firmware 1.46.

You might check this. The Keys my ‘VEX’ team received did not require updating, and the Keys I got this past Tuesday did not. however the BEST group I work with apparently got a different batch.

I did not know the keys could have their F/W updated, but it worked fine.

Cheers Kb

Looks like that was just released in the last couple of days, changelog says “security enhancements”, I imagine now that V4.23 in the cortex/joystick probably needs to see V1.46 in the keys if what I think was changed was in fact changed.

So I don’t have time right now to check this, but as ROBOTC V4.26 and EasyC are still shipping with the V4.22 master firmware, if new keys are now on V1.46 they may not be compatible.

You are correct, with the latest updates you must update the White Keys to version 1.46. Also you must update the Cortex and Joystick Master Code to version 4.23.

ROBOTC and EasyC software can not update the Master Code to version 4.23 at this time - you must use the Update Tools on our Web Site located here:

You need 2 Tools to do the Updates. The Tool for Updating the Whites Keys is called the “VEXnet Key 2.0 Firmware Upgrade Utility. The Tool for Updating the Master Code is called " VEXnet Firmware Upgrade Utility”.