Trouble with pros in ubuntu

Hello, I am trying to use vex pros on Ubuntu Linux and i installed atom and used the command: apm install pros-bootstrapper@0.0.12. I open atom and pros appears to be working but i get an error about the cli not being found even though i know it’s installed.

The procedure you indicated does not install the CLI. Atom is just a text editor, and you installed the PROS extension for Atom that provides convenient toolbar-based access to PROS CLI commands. In fact, you need neither Atom nor the pros-bootstrapper extension to make use of PROS; they are just provided by the PROS team for convenience.

Follow the instructions here to install the CLI. On Bionic (Ubuntu 18.04), start by running sudo apt install python3.7 to install Python 3.7. On Focal (Ubuntu 20.04), use sudo apt install python to install Python 3.8.

Once the CLI is installed, you should be able to run the command prosv5 --version.


Hi, thanks for the reply, I checked my python version and it said i already had version 3.8 but when i entered the command: python3.8 -m pip install --user, From the pros website, I got the response /usr/bin/python3.8: No module named pip. I also looked in my installed packages and the cli appears to be installed see attached screenshot. Screenshot from 2020-10-21 11-38-52

I know that for Linux Mint, at least, pip is not installed by default, but you can install it using apt. Try running sudo apt install pip. Then try running the command from the PROS website again

1 Like

Hey, i tried the command in terminal but i just got this output: E: Unable to locate package pip

The package name is actually python3-pip, thus the command would be:
sudo apt install python3-pip


i installed pip and tried to use the command but i was getting http errors and 404 client errors. I tried installing the source from git hub but i wasn’t successful there either.

What version of Ubuntu are you running?


Its version 20.04 focal

The full set of commands should be:

sudo apt install python python3-pip
pip3 install --user

Thanks, I ran the command you posted but I was still getting the cli error. In the end, I just ended up installing it on a windows pc I have.

@pompshuffle I use vscode with pros. I install the CLI using the pip install command found on there GitHub. And you’ll need arm-none-eabi. If you want to give it a crack again let me know. I would recommend Manjaro Linux it’s easier to get the required packages.