Trouble with


I am trying to run the example projects “Clawbot” and “Printing Text” on a v1 IQ brain, but I get the error: “User Program has exceeded time limit of 3 seconds”

I have tried turning it off and on again, restarting the IQ Brain and my computer, and
I have verified that both are fully up to date


How can I troubleshoot this?
Also, trying to run a blank project results in the same error. Doesn’t seem like I can get any project to run without this error.

1 Like

Second update:

VEXcode IQ states the robot brain is already up to date, but this is probably inaccurate.

I used the VEXos firmware utility to successfully update the robot brain, and VEXcode IQ works as expected. This issue is now resolved.

Now we’re cooking.

Hello! I was able to get the brain working by reinstalling firmware onto the robot brain using ROBOTC.

The error described above persists with VEXcode IQ 2.4.5 - 15, so I am using ROBOTC for now.

Which one is it ? Is VEXcode IQ working or not ?

What version of firmware was on the IQ brain, what did you update to ?


VEXcode IQ is working with my v1 IQ Brain, which the VEXos Utility shows as updated to 2.2.0.

Here were my order of operations:

  • Update the brain firmware using the latest version of ROBOTC
    • before this step VEXcode IQ showed the firmware as v0.0.0
    • after this step, ROBOTC programs began working as expected
  • Update the brain firmware using VEXos Utility
    • during the update process I think I saw the firmware version was 1.1.4 (not fully sure)
    • after this step, VEXcode IQ programs began working as expected

ok, vexos 2.2.0 is the latest. 1.1.4 is very old (several years, I forget exactly) it was probably something else, however, if it really was 1.1.4 I’m not surprised VEXcode did not work.

The vexos utility is used to update a gen 1 brain, VEXcode cannot update firmware for gen 1. If more than one application is open (ie. VEXcode and vexos utility or RobotC), communication to the brain would have been corrupted and VEXcode would probably have shown 0.0.0.

When RobotC installs firmware that’s usually the special RobotC runtime and not vexos, not sure why that would have had any impact other than to cause the whole program space on the IQ brain to have been erased.


Got it.
I agree, I don’t think installing firmware with RobotC as an intermediate step changed anything, I probably could’ve gone straight to updating firmware with VEXos Utility. Just wanted to note it.