Troubleshooting/debugging the robot

#1

I’m a student working with ROBOTC and the PLTW natural language with VEX 2.0 cortex. The problem I’m having is that one of the two motors my robot is using does not turn on. I’ve tried using a sample program that simply starts the motor, but it did not work. I tried using the debugger window and telling the motor to start at speed 63, but that did not work either. I think the problem is with the port it’s plugged into, port 9, on the cortex because I switched out the motor and the problem persists. When I try plugging it into a different port the debugger window still only gives me access to ports 9 and 4, which is the port the functional motor is plugged into. Of course, I did update the motors and sensors setup each time I changed the port. When I plugged the non-functioning motor into port 4, it worked as well as the other one. Has this happened to anyone else? Do you have any ideas on what I can do to fix it? Switching out the cortex is possible but it would be difficult and our supply of cortexes is limited. Also, this is my first post on this forum so if it is in the wrong category I apologize.

0 Likes

#2
  1. Post under EDR for cortex issues
  2. Can i see the lines of code your working with?
0 Likes