Troubleshooting flow charts not helping

I keep getting this error message with the followinglight configuration.

“No communication link available to VEX device. Check that your device is connected to PC.”

Lights on cortex are: ROBOT–slow blinking green
GAME-- fast blinking green

From that point forward I get nothing out of cortex. I have tried new batteries and orange cables but have so far only fixed it by swapping the cortex.

It will not let me update firmware either.

Any idea how to fix these cortex?

I am not an expert by any means, but here’s a couple of things that you could try;

Download the drivers for the VEX hardware here, and reinstall them.

Use the VEX IFI Firmware Loader to reset the firmware on the Cortex after you reinstall the driver. It’s installed on your computer if you already downloaded and installed EasyC. I BELIEVE that you also get it with RobotC, but I honestly have yet to order a license.

Use the Programming Hardware Kit to connect through the Cortex through VEXNet. I assume that you’re currently using the Male-Male USB cable, and that’s what isn’t working. If you’re currently trying to connect via VEXNet, then use the Male-Male USB Cable and see if that works.

Do you have another computer? Try installing the trial version of whatever coding software that you’re using on that and attempt the download.

I’m out of ideas at the moment, but if I think of anything else I’ll let you know.