Unable to Open PROS Terminal

I am unable to build the program or open the PROS terminal. I get the following error. Help on how to fix this error would be much appreciated.

Uncaught Error: Error launching WinPTY agent: ConnectNamedPipe failed: Windows error 232

Error: Error launching WinPTY agent: ConnectNamedPipe failed: Windows error 232
at new WindowsPtyAgent (C:\Users…pros-editor\packages\terminal-tab-plus\node_modules\node-pty-prebuilt\lib\windowsPtyAgent.js:25:24)
at new WindowsTerminal (C:\Users…pros-editor\packages\terminal-tab-plus\node_modules\node-pty-prebuilt\lib\windowsTerminal.js:45:24)
at spawn (C:\Users…pros-editor\packages\terminal-tab-plus\node_modules\node-pty-prebuilt\lib\index.js:27:12)
at TerminalSession.openPseudoterminal (file:///C:/Users/…/.pros-editor/packages/terminal-tab-plus/lib/terminal-session.js:52:12)
at new TerminalSession (file:///C:/Users/…/.pros-editor/packages/terminal-tab-plus/lib/terminal-session.js:19:21)
at file:///C:/Users/…/.pros-editor/packages/terminal-tab-plus/lib/main.js:33:47
at createTerminalTab (file:///C:/Users/…/.pros-editor/packages/pros-atom3/lib/util/Services.js:26:31)
at HTMLElement.didDispatch (file:///C:/Users/…/.pros-editor/packages/pros-atom3/lib/commands.js:135:14)
at CommandRegistry.handleCommandEvent (C:\Program Files\PROS\editor\resources\app\static<embedded>:11:345574)
at CommandRegistry.dispatch (C:\Program Files\PROS\editor\resources\app\static<embedded>:11:344049)
at ToolBarButtonView.executeCallback (C:\Users…pros-editor\packages\tool-bar\lib\tool-bar-button-view.js:130:21)
at ToolBarButtonView._onClick (C:\Users…pros-editor\packages\tool-bar\lib\tool-bar-button-view.js:109:12)

Same error I got and could not find documentation on. It’s the reason I use vexcode over pros :grinning:

I don’t think most of us know what the problem is, or else it would be fixed.
Try reinstalling PROS.
In the worse case, you will have to use the CLI (which I do anyways) instead of the editor buttons to compile and upload.
Its very quick to type prosv5 mut and Ctrl-C+Up+Enter to repeat.

This is a known issue with WinPTY. It has nothing to do with PROS so much as your antivirus software (apparently McAfee and Avast are known to cause this problem, but others may too).

I’m not so sure about that. The same issue affects VScode and other projects, so it is actually quite well documented.


To fix the issue, you need to locate winpty-agent.exe within your PROS installation, and then exclude it from your antivirus software’s scanning.

4 Likes

This worked for me thanks.

1 Like