Unable to upload to v5 brain

No matter what I try, I’m unable to upload my program to a vex v5 brain. Whenever I try to upload, I get an error saying no v5 ports were found:
Capture

I have tried:

  • wireless and wired upload
  • different cable
  • different port on the same computer
  • different brain
  • multiple programming interfaces
  • several of the previous at the same time

My best guess is some sort of driver issue, but I have no idea how I would go about seeing if this is the case or how to fix it if it is.

Does VEXcode say something is connected when you plug the brain into the computer?

Also in the error message, have you tried running the command again using --debug flag?

1 Like

The vex firmware utility shows no devices found
Capture1
and running with the debug flag doesn’t seem to yield any useful information.
Capture2

Make sure to try downloading from a different computer.

1 Like

Other computers can upload to my brain without issue. I have also tried using new projects in my programming interface; same issue.

It sort of seems like its the computer which is a problem.

There is a chance the USB ports have been disabled or broken in some way which is stopping them working. Are you able to plug in a mouse or keyboard? or other USB device?

You might need to use a different computer if you can when programming. Unless you can get someone to have a look at the computer to try to fix the problem.

2 Likes

Any other USB device works fine on the computer. I have also tried running it on another computer, and it was unable to upload as well. It’s possible there might be an issue with the most recent version of PROS I am using, but other programming environments are having similar issues.

I’m guessing VEXcode V5 doesn’t work either?

Do you know if the cables you tried have the ability to transmit data? Some cables only do power and that is insufficient to upload to the brain. Has this cable worked for uploading before?

1 Like

This cable has uploaded before, and I have tried several cables.

check you can see the V5 in the device manager.
image

If the V5 is not there under ports, nothing will work.

1 Like

The COM & LPT header is not present at all.

No ports, then no header.
so that’s the issue.
either something on this PC is really messed up or the drivers are not loaded for some reason.
reinstalling the V5 firmware utility should reinstall drivers.

1 Like

Also make sure Ports isn’t disabled.

Reinstalled the firmware utility and still nothing. This computer also has a fresh install of windows; there’s only PROS and the firmware utility installed right now.

Not sure I even know how to disable Ports, but then again I’m a Mac user…
and I guess I would cover that under messed up, I’m sure there’s a dozen ways to create USB problems under windows.

1 Like

I would hazard a guess that you know substantially more about Windows than the average Windows user.

2 Likes

Usually you can right click and choose to disable it/ reinstall it.