"Unknown Error" problem only shows up on certain computers

I have 12 Vex IQ robots and 10 Macbook identical laptops. Only 4 of the laptops consistently send the saved programs we are making in Modkit to the brain. The others all say “Unknown Error.” From reading other posts, I know to check to make sure the names avoid certain words. I can take the same program and create it on one of the “bad” laptops, save it, and then log in and load it on one of the “good” laptops and then the program will load and run on the robot.

I have tried restarting the robot, restarting Chrome or Firefox, restarting the laptop, and restarting Modkit link. Nothing will make the “bad” laptops work. I have tried deleting the Modkit Link software, redownloading it and reinstalling it. I have even taken a downloaded dmg copy of the Modkit Link software that did work on my laptop (which is newer) and tried to install it from that dmg.

Is there something else I am missing? Are there some settings somewhere else I can delete to reset the program settings?


We are sorry that you are having this problem. What version of OSX are you using? When you are running Modkit Link, do you see the yellow M icon in the top right side of the menu bar?

The newer versions of OSX contain a security feature called Gatekeeper checks programs downloaded from the Internet for any viruses or similar. However, in version 10.9 the default security setting was changed to only allow programs from the Apple App Store by default. You may need to add Modkit Link to a white list of allowed programs to allow it to run.

To change this setting, first try to open Modkit Link from the Applications folder. Then, please go to the Security & Privacy pane in System Preferences, and you will see a message that says 'Modkit Link" was blocked because it is not from an identified developer. Click the Open Anyway button to allow this program to run. We are currently working to make sure that Modkit Link correctly identifies the developer as Modkit for the future.


  • Art

We aren’t running 10.9 on the older laptops. Modkit link is running. The Modkit webpage sees the Vex IQ controller after when it is detecting hardware. It works on that part on all the laptops. It just runs into the “Unknown Error” when downloading the program.

We have the same problem when using Modkit on several computers. I’ve seen the problem on Mac and Windows. Seemingly random things cause it. Sometimes changing which port something is hooked up to seemed to fix it, or getting rid of certain blocks. I can’t seem to find any rhyme or reason to it.

Maybe could you explain how Modkit works? After using it all semester for an after school club, I’m starting to suspect that Modkit doesn’t compile my sketches to actual code that gets compiled to a ARM binary to run on the raw metal hardware. Is this correct? It would explain a lot of the interesting bugs we are seeing. I’m assuming now that it compiles to some sort of instructions that the modkit firmware interprets and runs. Is this correct?

And along with this, if this is the case, is there any way the specs of vex iq could be released? It would sure be great to be able to use gcc for arm to cross compile our own binaries…