UNOFFICIAL: Brain not responding to controller...Help

Can you post your code?

might sound dumb but how to I upload it to a comment so u can view it?
and thx for answering

@catastross
One way to post it is by clicking the code button in the top header with the symbol </> and copy and paste it between the code] and /code. Another way is to attach the actual code file using the Attach a file button on the bottom left of the reply screen.
Hope this helps.

can’t seem to get that working, but the code is basecly this
Forward (1, rotations, 50);
Move motor (armMotor, 1 , degrees, 50)

update- the code is now working, I do not know why, but when we turn the robot on it runs it randomly, it still doesn’t respond to the controller

@catastross Give this a try. In RobotC, Click Robot > VEX Cortex Communication Mode > VEXnet or USB. Then, re-download your code. If you have USB Only selected, the Cortex will not recognize a VEXnet Joystick or VEXnet Key as being connected. I attached a picture for reference.

[quote]
Hello there,
I am working on your vex robotics vehicles in school, and recently we have finished it and we were satisfied as it worked flawlessly, so we decided to start working on programming our creation, we used the simplified version of your 2 coding soft wears but as we made a simple code line and tried to download it to the robot, it stated that we had to update out soft wears, and so we did, for the controller and the brain, and as we later on downloaded the code line, the controller and the brain weren’t responding to each other, even if all the LEDs were fully green and not flashing, we believe that is was an error in the keys and so we switched to USB A to A cable that we used to download the soft wears, although that also didn’t work, so we ran out of theories and got to the Web, but none seemed to have the same problem or at least couldn’t find anyone with the same problem. Help?

Thx for the help.
[/quote]
VEXnet or USB.png

At my school, we have a similar problem where our brains only respond if we turn the controller on with the VEXnet keys first. They do not respond what so ever with the 2-way USB cords, which we’ve seen other teams do successfully. Would anybody here be able to explain this, or would an alternative option (such as the crystal radio connectors) be a better option than the VEXnet keys? Or is this just the default way that the VEXnet keys work, and if so, is there a way to change this?

Can you provide more details.
Does the joystick talk to the cortex at all with USB A-A cable? What do the LEDs do? or Does the Joystick with the USB A-A cable talk but you cannot program the cortex using the programming cable?

White or Black VEXnet keys?

Is all the firmware up to date?

are you using ROBOTC?

as of after I done what you pointed out it did make the vexnet LED light up, but now it’s flashing green rapidly, and the robot light is flashing green slowly, the joystick is continuously light up (when using vexnet keys)

@catastross Flashing green rapidly on VEXnet means the Cortex and the VEXnet Joystick have paired successfully. This is the link to the VEXnet User Guide.
On page 8 of 14, it lists the LED patterns and meanings.

Would you be able to post a picture or like 2 second video of this? Try the following as well. Be sure to download the firmware in the order specified.

  1. Download Master CPU Firmware
  2. Download RobotC Firmware
  3. Download code again
  4. Download Joystick Firmware to the controller
    5)Update the VEXNet Keys

The first 3 should be done before testing it again because master CPU Firmware deletes the code and the robotC firmware from the cortex. Then continue testing. If these don’t work, try to post your entire code. It might be an issue with the competition template, because I remember in NBN once, the new template was causing problems. I know you said you couldn’t figure it out, but try again. That very well could be the problem.

So, i followed your instructions, but still can’t get it to work, i would upload the video that i made today but my phone is being a pain and can’t send it to my pc, i’ll try and find another way to upload it later on

got it working
20170629_153752_002_001_001_001_001.zip (27.1 MB)