Unofficial: ROBOTC Compatibility with Macs

@avp08:

ROBOTC requires Windows. To run ROBOTC on a Mac, you will need to use Windows with Boot Camp or a virtual machine (Parallels, VirtualBox, etc.).

You could also use PROS instead of ROBOTC. You can run PROS without having to install Windows on your Mac.

Thanks!