Unresponsive to joystick inputs

Our VEX Cortex 2.0 robot is no longer responding to joystick inputs. We have updated all software and firmware, and all the lights show that the robot and the joystick are linked. We have tried switching joysticks, switching cortexes, changing batteries in both the cortex and the joystick. The lights are all green and according to the troubleshooting manual everything should be working properly. We have updated the keys numerous times. The problem randomly appeared after we turned the robot off to change a physical aspect of the robot, then turned it back on. The robot will perform programs downloaded to it, just not inputs from a joystick. Any help would be welcome. After 2.5 hours of trouble shooting and resetting and updating, we are at a standstill. The robot has been communicating for weeks leading up to this, so we do not understand the cause of the problem, but are in desperate need of a solution, as we are competing in 5 days.

Thank you for any help,

Hi Theresa,

This is an interesting problem. We’re sorry that you’re having it.

Have you tried downloading default code then testing the joysticks?

Can you post your code using the “code” tags?

I look forward to hearing back from you,

We are not using any code on the robot besides the default code. We are strictly trying to control the robot with the joystick. We are not attempting to use any code for autonomous control.

Just to be sure we are actually using the default code you are talking about, can you tell me where we should be downloading the default code from?

Thank you,

You can download the default code by using the VEXNet Firmware Upgrade Utility provided by VEX; download, install, and run the Upgrade Utility, then connect the Cortex to the computer. This will give you the option to download the latest Master Firmware version and the default code to the robot.

VEXNet Firmware Upgrade Utility: http://www.vexrobotics.com/wiki/Software_Downloads#2_-_Update_Firmware_on_Cortex_Microcontroller.2C_VEXnet_Joystick.2C_and_VEXnet_Key_2.0

Please let us know if the joysticks work with the default code loaded onto the Cortex.