Unusual Disconnection Issue

Whenever our robot goes to hang in autonomous, it constantly disconnects midway throughout the hang. Whenever this is attempted in driver control, the hang finishes successfully even though it’s the same code running to do the hang (auto and driver share a routine). We have a backup battery plugged in and have tried it with and without a usb extension to improve vexnet connectivity. I’ve tried powering the controller on it’s own batteries instead of through the programming port and the problem still occurs. Has anyone ever experienced something like this before? Any help would be greatly appreciated.

Try to pay attention to your cortex while this is happening. it may be disconnecting causing everything to reset. Also, check your code, you may have some fail safe or command that is interfering with the hang. Posting you code would be helpful, but I understand if you want to keep that to your self.

We had a problem recently where our robot would constantly disconnect throughout the match despite having full batteries, a power expander, a backup battery, a new cortex and new VEXnets. We had no idea why this was happening, and just a few days ago we figured out that the battery was coming loose in the battery extension cable, causing the cortex to disconnect and then reconnect several times throughout the match. Once we replaced the extension cable, all was fine.

We know that it’s disconnection as we can see the lights on the controller and cortex. The lift and drive failsafes are disabled during the hang because of the high strain. We’re not using a battery extension cable and even if the main battery disconnects the backup battery should keep the vexnet connection alive, I’ll check all the connections though.

Andrew, does this happens when you use a tether cable between cortex and joystick? Have you confirmed that the backup battery is working by turning of main power? (you will ned to be under field control for this to work).

I haven’t tried this with a tether cable as it’s quite difficult to do a auto skills run with a cable but I’ll try that later. I’ve confirmed that the backup battery is functional by turning off the main power.

Here are my personal thoughts/procedures through my experiences:

  • Have you replaced the joystick and CORTEX batteries? Sometimes this will help. A Red Remote indication can cause disconnect issues.
  • Have you tried replacing your battery extender with another one? Sometimes the clip doesn’t hold as good.
    If these aren’t any procedures that help, I can come up with more :slight_smile:

I’ve made sure all batteries are full and I don’t use a battery extender for the main cortex battery. Even if it did become unplugged, the backup battery should keep the connection alive.

If this happens every time during autonomous, It may be worth writing some debug code to try and help diagnose. Add a task, wake it every 10-20mS and monitor main battery, nVexRCReceiveState and anything else that may be of use.

Does the hang rely on any sensors? Do you have a power expander involved?

I’ll write some debugging code tomorrow to monitor battery voltages and the transmitter status. The hang relies on a potemeter on the lift and claw and a power expander covers half of the lift and drive.