Update Problem

I am teaching a class of 30 kids. All the Vex IQs are having the same problem. They keep displaying “Connect to PC for Program Update” but when they are connected, they are not seen.
I have tried:

  1. Only updating the brain–not the problem
  2. Using different update cables–no change
  3. Using different computer ports–no change
  4. Using different computers–no change
  5. Using different batteries–no change
  6. Using different brains–no change
  7. Turning it on and off–removing the battery
  8. Next step? Using them ALL as paperweights???

When connected to a computer (via USB cable), is the VEXos Utility Running on the computer: (Link below)

1 Like

I notice that the Vex OS has an update from March 2019.
I don’t believe my tech people have updated it.
Do you think THAT might be my issue?
I will contact them and have them rush a new install if it is.

Maybe,

When the VEX IQ brain is in need of a firmware update, it shows a start up screen that says:

VEX Robotics Inc. DFU
Connect to PC for
Program Update
V1.01

Also, you can force an IQ brain into this mode by holding Up and Down buttons while pushing (Check) button to turn on the Brain. You may want to try that to see if that gives you something else.

Paul

Well, I am at a stop for all my Vex IQ kits/brains/students until I can manage to figure out why every one of them say “Connect to PC for Program Update” They all say V1.01
I will see if the tech people can reinstall the VexOS and see if that fixes the problem.
This is so frustrating. I will have to switch to NXT for a few days with my class…

This issue is that the VEX IQ brains are in “Firmware Update Mode” (DFU), so they do not currently have a VEXos version loaded on the Brain.

Assuming this issue was started when you were updating your IQ Brains using the VEX OS Utility, that utility will send a message to the IQ Brain to put it into “Firmware Update Mode” and then wait for the VEX IQ Brain to reconnect to the computer.

However, if you’re using school computers, there’s a chance that your security permissions are not allowing the VEX IQ device drivers to be installed as the VEX IQ “appears” as a new device type to the computer when in this firmware update mode.

I’m afraid your only option will likely be to connect with your school IT Admins and ask them to allow the VEX IQ Brain in “Firmware Update Mode” to be recognized by the computers.

1 Like

Well, I contacted tech. They updated the program on our computers in the lab to make sure it was the right version. IT Admins made sure we all have access…and I’m still not getting anywhere with the updates.

It’s as if the computer just doesn’t recognize that the things are plugged in and turned on.

I have a screwdriver and am taking them apart now…ugh

If you can access Device Manager see if anything shows up there when you plug in the IQ brains.

If ‘Unknown Device’ or anything else doesn’t appear, then that could potentially suggest that it is a problem with the brains themselves.
If ‘Unknown Device’ or anything else does appear, I’m guessing it might be an issue with the brain interfacing/being recognized with/by your computers as mentioned by tfriez.

1 Like

Well, I took it apart and discovered that nothing is loose. The power connector is solid and the cable connects well. I’m at my wits end. I have 30 students and no robots working. I have some NXT kits so I guess we will have to discontinue VEX IQ and move on to Lego. So frustrating.

Can you try a computer that is not on your school network (at home for example) and run VEXos from there?
Did the last batch of updates finish properly? The brains require power cycling during some updates so turn themselves off and need to be turned back on midway through for the update.

1 Like

The Device Manager sees it as Device Firmware Upgrade.
If I turn off the brain, that disappears.
When I turn it on, it reappears.
When I unplug the USB, it disappears.

All the bots worked in June when we stopped for summer…

I will take one home and run it from home to check that out. I will really be upset if it works…because that means that IT did something over the summer to our computers…

If it is a large number of brains that are seeing the issue, I think it is unlikely to be a hardware issue and more likely to be an IT issue. I hope it works for you at home so you an find a way forward. Good luck!

2 Likes

Absolutely. Thank you for helping me think through this. I will let you know what ends up fixing this problem.

1 Like

The other thing to keep in mind is that no other applications should be open while trying to update firmware (I.e. don’t have VEXcode IQ Blocks open)… also, there’s always the chance that there is other software (security software, various utility applications) that might be stealing access to the IQ Brain as it shows up as a standard Serial COM port.

The fact that the Windows Device Manager sees the VEX IQ Brain in Firmware Update means the hardware is operating properly, but something on the computer is tying up the communication port to the robot.

I would double check with your IT staff again and ask them if there’s anything on the computers that would be blocking access to Serial COM ports.

1 Like

Your #1 of your original post implies no problem updating brain, but message on screen says brain did not update…

Ok, sometimes I have had to

  1. pull battery to turn off, battery back in
  2. connect to PC with only latest version VEXos Utility (firmware updater) running
  3. turn on brain into DFU by
    holding Up and Down buttons while pushing (Check) button to turn on the Brain, as @Paul_Meyers1 said above
  4. follow prompts
  5. on occasion I have had to close and reopen VEXos Utility when Brain is waiting and not being recognized to get update to finish. Need to wait a bit sometimes, too. Not very long.
  6. And sometimes pulling battery and restarting brain normally while connected, then opening VEXos Utility has triggered recognition.

If all this doesn’t help, maybe you can give brain and cable and this forum thread to IT staff and say “help, do this”?

2 Likes