Upgrading to 3.54 made even USB connections not work

Having trouble getting 3.54 upgrade to work.

Was on 3.08 and looking to use I2C sensors (again) so it’s time to upgrade. Yeah! Also new team members downloaded the latest version so we should be consistent. Unfortunately after the upgrade even the USB-USB does not see even the robot. Boo!

Do I have to uninstall completely and try again? What is the means of cleanly uninstalling all the way? Do I have to try re-installing some drivers? Are there more diagnostics I can see?

I posted a question over at robotc.net too but I know this forum is much more active.

I am using Windows 7, and the 64 bit programming drivers all taken from the start page in robot C. The profilic drivers are not even in the troubleshooting yet since I am USB-USB only right now to get firmware loaded.

Before the upgrade we were able to download and run programs just fine. Running the debugger seemed to get more vexnet drop outs but we don’t have a 9V battery installed right now so I will chalk it up to that.

So I upgraded to 3.54 like robot C wanted and it all seemed to go just fine until I went to download the firmware to the robot. Then nothing worked.

The select communications port shows me the USB cable just fine on whatever USB port I stick it into. The install drivers for USB cable says it was OK. I select download via USB as my communications preference too.

The USB-USB cord is a proven winner used to pair many a cortex and joystick so I like that guy.

Testing the communications in the robot menu also says there is an error saying the selected file can not be found.

So I tried a few tricks I thought might work but all no luck.

  1. I tried the Vex firmware utility and that can not read the robot either.
  2. I tried running that as administrator and also in Windows XP sp3 compatibility mode - no luck
  3. I tried running robot C in compatibility modes too. No luck there either.
  4. Rebooting

What can I use to diagnose the problem further? The USB drivers say they look OK. The communications port shows up properly in the robot C communications dialogue selection. What gives?

I am wondering if my computer is cursed since I had 3.08 upgrade issues previously too but can not for the life of me remember how I got that to eventually work.

I really want to standardize on 3.54 for our club as new members are purchasing and downloading 3.54 to their laptops, but this upgrade path is scary.

The ‘Error 2(0x2) The system cannot find the file specified.’ issue is known COM port handling issue and we are currently working on a fix. In the meantime, you may want to download and install the 3.55.2 Beta (link below) that should solve this issue. I apologize for any inconveniences this may have caused, and as always, we appreciate your feedback on any and all issues you may come across in ROBOTC.

3.55.2 BETA link: http://www.robotc.net/forums/viewtopic.php?f=52&t=5122

Thanks for the quick response! I’ll try it in a few hours when I get home.

Any idea when that beta might be rolling out to full release? I’d like to try and standardize the club on a single version if possible.

This worked. Thanks!

Now on to the next problem - a whole set of stripped screws. Sigh… Good times.

We try to release the updates as soon as possible, but we also want to make sure they are as bug-free as possible before they go live. The best thing I can recommend is keeping an eye on our blog (www.robotc.net/blog) as we post on there whenever any major updates go live.

Unfortunately there isn’t a whole lot I can do about the stripped screws. Let me talk to our development team and see if we can implement a ‘setStrippedScrews’ command…

If only it was that easy :slight_smile: