[URGENT] Brain freezes completely when plugging into computer

Hey all,

I tried downloading some code off of VEXcode IQ, and when I plugged the robot into my computer via the micro USB cable, the brain just completely froze. When I checked in VEXcode, it said there was a brain plugged in, but the version of the brain was 0.0.0 (yesterday, it was the latest, I think 1.0.4). Downloading the code just gets stuck on “Downloading user project”.

What I’ve tried:
Getting a new cable - also doesn’t work
Using another computer - I’ve tried two windows computers, both to no avail
Using another brain - I even tried plugging in my spare brain, and that also didn’t work

I have no clue what to do, it clearly wouldn’t be my computer, brain, or cable, since it doesn’t work when I swap them.

Any help would be greatly appreciated, as I have a competition tomorrow and need to finish up our auton code.

well, it’s one of those three, what else is there ? perhaps your code, try a new simple project.

You are in the IQ section of the forum, is this a gen 1 or gen 2 brain ?
(if gen 2 then vexos 1.0.6 is the latest)

so you plugged this in and the brain completely froze in exactly the same way ?

Have you tried rebooting the PC ? (or Mac, you didn’t say).


Yes, I restarted both PCs (I did say they were windows)
This is a gen 1 brain, the version is 2.2.0

Yes, exact same way on both computers.
New projects in C++, Python, and blocky also don’t work.

Try using a different battery. Prob the battery is bricking the brain.


Used the web-based VEXcode IQ. (codeiq.vex.com)
For some reason, this works with the exact same environment (same cable, brain, and computer)