Urgent motor help

I was running my autonomous then needless to say, something happened. Our right drive train has trouble moving forward all of a sudden. Our right drive is powered by two motors, both in the autonomous and driving it could move backwards just fine, but the right side moves significantly slower moving forward.
After laying the robot on its back, I tried to spin it with my hand, it spins backwards just fine but has a lot more resistance forward (the robot was off for this)
Also any time I try to run it with electricity it makes that high pitched beep, I think you all know what that is.

Does anyone know what is happening? How to fix it? We desperately need help here.

I would be happy to clarify anything, we have a tournament in 2 days.

if you can I would just replace the motors and try to figure our the problem ones afterwards, if this isn’t an option, then idk what exactly is wrong with them. is it that the motors on your right side spin slower in one direction? what exactly is the behavior of the problem motor(s)?


So lets say:
I drive backwards, both sides drive backwards at 100%.
But if I drive forwards, the left side drives forwards at 100% while the right side only at about 50%.
When I spin the drive with my hand, there is clearly resistance in the right side spinning forward.

yes, but what exactly are the individual motors doing? are both motors on the right side only spinning at 50% speed when going forwards, or is one not spinning at all and the other spinning fine? do you have 2 motors acting weird or just 1?


I just unlinked the connecting chain. The front most motor is causing the issues but the back is fine.
Trying to run it, the motor isn’t moving at all and is making the high pitched beep, the port is not flashing btw.
I’m going to slide out the axle right now to see if that has anything to do with it.
Thanks for pointing out I can replace it, I was so flustered trying to figure out how to fix it I completely forgot about that part. Worse comes to worse I will do that.

I removed the axle and the problem is isolated. One of the motors doesn’t spin anymore and makes the beep every time it tries to. I don’t know how this relates to going backwards fine but not forwards, either way it definitely ain’t spinning.

it’s probably fried. if the light on the motor is off and you can’t turn it manually (when the robot is on) I seem to remember that indicates a fried port on either the motor or the brain. have you tried switching ports yet?


I just changed ports and nothing changed in the motor.

The light is on, I can turn it manually when the robot is on, but it struggles turning clockwise. I should note that I can turn every motor when it’s on.

I’m going to replace it for the time being. Thank you for your help (and reminding me I can replace it to begin with), I greatly appreciate it.

For the topic, if anyone knows what is happening I would love to hear what you have to say.


is it difficult to turn by hand?


Incredibly, I just got it off and shoved a high strength shaft in, counterclockwise feels fine but clockwise feels almost impossible to turn. After I eat dinner I’m going to remove the cartridge to truly see what is causing the issue.

interesting, that sounds like a mechanical issue with the motor then. I have no idea what could be causing such resistance in only one direction, taking it apart might give you some answers if the problem is in the cartridge or external gears.


Yeah, this has happened two us twice in the past. Our only solution was replacing the motor :man_shrugging:

1 Like

Update, I replaced the motor and for a few seconds it drives fine, but then after maybe 3 seconds of driving the same thing happens. Once I let go of the joystick and press it again it resets and will struggle in 3 seconds again. This is tough to explain, but I’m going to completely change the port (if we still have one) and see what happens, after that I will look at the cable.

Also, I took the cartridge out of the other one, it seems like without the cartridge it can spin fine but once it goes in we get the issue again.

interesting. so the replacement motor that was fine broke in the same way as the first?

it sounded like a mechanical problem with the difficulty you had hand-turning it.
were you turning it while it was connected to the brain or disconnected?

1 Like

Well, this one is weird, this time it’s only when it’s been spinning for about 3 seconds.
For example: Drive for 3 seconds, the right train hits the brakes. Then I stop driving for a second and it’s fine but then after 3 more seconds of driving it brakes again.
I couldn’t spin this one by hand because of this, so I walked it around the field just pushing it along. Every couple of moments both trains would hit a brake for a moment, sometimes just the left, sometimes just the right, the robot was off for this push test.

if it was connected when you tried to turn then I’d say sounds like a software problem.

1 Like

Funny thing, I actually forgot to connect that motor, I’m gonna test now both connected and not.

wait so both motors had resistance to manual turning while not connected to the brain.

I’m gonna start from the top of the new motor.

A: I forgot to plug it in but the chain linked it to the motor it was sharing power with, every couple of seconds the right side hit the brakes.

B: I pushed the robot and every once and a while both sides braked.

C: I realized I never plugged the motor in.

D: (Just now) I plugged in the motor and it worked fine. It’s driving in a perfectly straight line with no brakes at all.