USB Serial Cable Driver

Hi, this is essentially the same post that I made in the “Ask the experts” section.

I have been able to program the robot in the past, but recently I had to uninstall everything (including the driver for the USB-Serial adapter) and reinstall it all.

Last on the reinstall list was the driver for my cable. I installed the latest Prolific driver and plugged in my cable. The device manager pop-up appeared in the task bar and said “searching pre-configured driver folders…” then “Searching windows update…” then “Installing driver software…” and then I got a message saying “A service section of thin INF is invalid”.

No matter which version of the driver I use, how I try to install it, I ALWAYS get the same message!

Anyone got any Ideas, have the same problem, etc?

What version of Windows? What version of Driver?

You have downloaded this PL2303 Driver???

It sounds like you are Stuck, you can not go forward, nor go backwards…

Here is what I have done in the past…

(This is with Win2000 and WinXP_32. WinXP_64 and Win Vista might have different file names)

I would boot in safe mode .

Search through the files in the “%windir%\inf” directory for the text “Prolific”. If no matches, try the same Search for the text “”. Search for text in the files, not file names.

You should locate at least One file (mine is “oem5.inf”, YMMV) that references the files, ser2pl.sys, and serenum.sys.

If you can not locate those File Names. look for anything that has a “.cat”, and “.sys” and the end, and use those names.

Delete (or Copy to a Flash Drive, if Paranoid) the *.inf, the .cat and the .sys files. found above, BUT ONLY THE FILES REFERENCED IN THE .INF FILE WITH THE NAME “PROLIFIC” IN IT, AND THE .INF FILE ITS SELF!!

Unplug Vex USB to Serial Cable (if not already done)

Reboot to Administrator Mode

Unzip and Install Driver referenced above.

Plug in Vex USB to Serial Cable.


The above steps should:

Remove the OLD PL2303 drivers from the system.

Install the NEW PL2303 drivers to the system, with out detecting NEW Hardware and accessing the Internet (and possibly downloading the wrong drivers).

When the Vex USB to Serial Cable is plugged in, everything that it needs should be there for it to operate correctly…


If that fails you you might need to use the USBVIEW.EXE program from the Micro-Soft Device-Driver Development Kit (DDK) to find out Vendor ID (idVendor) and Product ID (idProduct) for the USB to Serial Device. (They Should be “0x067B” and “0x2303” respectively.)

Hey, thanks.

I haven’t actually tried any of that yet, thought I’d let you know I am rinning Windows Vista 32bit and I have downloaded all the versions of the driver that I could find (including several for Vista) and tried them all using device manager.

I will now go and try what you have suggested, probably won’t delete anything, but I’ll tell you what files I find.

The solution found here may be totally unrelated and useless but worth investigating. It deals with a different application but the USB-RS232 is the same ‘Prolific’ device. If the worst comes to the worst simply unplug the USB-RS232 adapter and plug the RS232 straight into an RS232 port on your PC (if it has one) then set RobotC (and possibly EasyC) to use the serial port you have plugged it into.


I did a full sustem search for file contence as well as names, found a bunch of files and deleted them all.

The driver MarkO referenced, while failing like all the others, actually said “Could not copy inf, Installation failed!” The next time I tried to install it, I opened the folder it was creating and saw a .cab file, an .inf file, and the third file was ither .sys or a log file. After I hit finish on the installer, the .inf and the other file dissapeared leaving me with the .cab file.

So, I finaly know why it says “A service section of this INF is invalid”, there is no inf to begin with!

I still have not tried USBVIEW.EXE yet.

As for ChrisHam’s suggestions, unfourtunately I didn’t find the site you referenced to be much help. I am also sad to say that because my computer is a newer model, I do not have a serial port.

So the issue now is, how do I get around the installer saying “Failed to copy inf…”?

Thanks to all who have helped thus far.

OK… That sounds good…

(In a voice like Spock from Startrek) Fascinating…

It sounds like you don’t have permission to install the Driver…

When you installed the driver from the Prolific Site, you did a Right Click on the File in Windows Explorer and selected “Run As Administrator”, and got the User Access Control (UAC) Darken Screen and Dialog Box??

The files that you could see until the Finish were the Temporary Files, that were cleanup at the end of the Install…

The .CAB is a Micro-Soft Cabinet File, which most likely contains the above files you saw, Unpacked, attempted to Install and then Deleted.

Or the Installer is unable to copy the .INF to the correct Destination, or something in the Hardware Detection is accessing a section of the .INF that is incorrectly configured for the Hardware susposedly in your System.

I have installed this exact Prolific Driver on Win32 Vista on a HP. So I know that it works (for the most part) (I also installed EasyC 1.1 on the same Laptop as well, See Vista and EasyC 1.1)

It sounds like a permissions issue… You DON’T have Permission to install the Driver.

If “worse comes to worse”, there might be something about your particular Laptop and the Prolific Drivers…

In that case, a different Brand of USB-to-Serial device might be in order, The Belkin F5U109/409, the Keyspan, the older Radio Shack (with the Radicom chipset), and I/O Gear, I am very sure Don’t use the Prolific PL2303 chip… There is Nothing Special about the Orange Vex USB-to-Serial and the Vex Controller, any USB-to-Serial device will do. The Orange Vex Programming Dongal is Special, and you will still need it, no mater which Serial Port you use.

I pretty much run everything as administrator these days, the driver installer included. I did this with the instasller and got the UAC window, hit continue etc. I have had premissions issues in the past, not being able to delete stuff and the like, even with full administrative rights. I’ll look into the premissions some more, but, with other versions of the driver that didn’t produce the message “Could not copy inf…” could there be an issue with driver signing?
I actually have ROBOTC, which had some issues of it’s own, but I fixed those right about the time the driver STOPPED working, which brings me to my next point. As I said before (but maybe not clearly) I have been able to use the programming cable fine in the past, but in order to fix ROBOTC, I had to uninstall and reinstall EVERYTHING that had to do with programming (ROBOTC itself, IFI loader, and the driver) after this I got the “A service section of this INF is invalid” message.

Hope that didn’t take too much time to read and Thanks again.

I was focusing on the USB-to-Serial Driver…

Try Uninstalling the USB-to Serial Driver (again). Follow the steps I outlined above, but before re-installing the Prolific Driver, Get CCleaner, and run at least the Registry Cleaner Part, don’t forget to make a Registry Backup… It might not hurt to CCleaners main CleanUp part as well…

I got CCleaner and ran the redgistry fixer and the regular cleaner.

All that happened was I got the error:

Can’t copy inf file
Failed to install!!!

I have gotten drivers from and

No real advance there, but CCleaner is great!

Thanks for bearing with me.

and [

No real advance there, but CCleaner is great!

Thanks for bearing with me.](

WOW!!! This is very perplexing… I have actually been working with Prolific PL2303 USB-to-Serial adapters since APR-2002, and have supported them being installed on just about every version of Windows.

If you have another Win Vista system installed with the Prolific Drivers, you might check the .INF, .SYS, and .CAT files and locations as well as the Registry to see what they are and see if adding them by Hand will do the Job… Something is “broken”, and needs to be fixed…

Yea, I tied the trick on this page :, only I used the second driver on this page :, rather than the link in the instructions.

This got me the “PL-2303_loggedDrv” folder as described in the first page I referenced above. I told Device manager to search that folder and it said “The best version of this driver is already installed” or something like that, the funny thing was, it didn’t have a driver installed (the properties page in device manager said “No driver installed (Code 1)”.

That aside, I was trying to figure out the whole “Permissions” thing, as in if you right-click on a folder, hit properties, and under the security tab where it has the premissions settings.

First, what does ownership do?
What are “Special Permissions”?
What are “Inherited Permissions” and what do they do?
Are there “Permissions that control other permissions”?
Is there a way (or tool I can use) that I can take ownership of almost all of the files and folders on the computer (like some sort of "batch permissions tool)?
When I tried to change permissions on the “Program Files” folder my access was denied on all of the sub folders, why and how can I fix this (preferably without doing it to each sub folder individually)?
And lastly what does access mean/do/affect and how is it different from permissions?

That’s a lot to sort through, and it may seem off-topic, but I believe if I can fix all or most of the above issues I will be able to properly install the driver on my computer then, with luck, on the cable itself.

Thanks so much for sticking with me.

Hang in there!! I am looking for answers for you…

I have a solution to the Vista 64 Bit serial cable problem! My solution was to purchase a brand new USB to serial conversion cable from of all places, Radio Shack and it worked perfectly. I can now program my Vex Controller from my HP laptop while taking advantage of the laptop’s high processing speed.

I am curious… Radio Shack’s USB to Serial adapter at one point had a Radicom Chip in it, then I saw some that were identical to the Vex USB to Serial adapter, except in the Color was White instead of Orange.

Do you know what Drivers and Chip Set is used in the one that you purchased…

Hi MarkO,

The carbon black cable (260-0949) that I recently purchased is the Gigaware 6-ft USB-A to Serial Cable and the pacakage states that it is Vista compatible. I am not sure what USB IC Chip it uses since it is sealed.



Hey guys.

Due to this problem and several others that have come up over the year and a half I have had this computer I decided to do a clean re-install of Vista 32. After much updating, the problem was eventually resolved (for now!) and hope never to encounter this problem again!

From these results, I can only guess that there was some sort of registry problem beyond the capabilities of CCleaner, a USB root hub issue, or some sort of misinformation/corrupted data hiding some ware in the bowels of my computer.

This does not mean that another cable would not have worked, and if I ever have this problem again (I REALLY hope I don’t), getting a cable with different chip will be the first thing I do.

Thanks to all who contributed.

As a post note re the same problem for me.

First I ran CCleaner on registry… no fix.
Then I used the CCleaner tools to uninstall Prolific Driver …no fix

Then went back to CCleaner uninstall tool and deleted the prolific entry. Then reinstalled prolific from prolific website. And bingo…problem solved.

Maybe…don’t need CCleaner if you just uninstall with windows uninstaller. Didn’t try that.

It has been my experience with using USB-to-Serial converters for the last 8 years that Micro-Soft like to break then every once in a while.

If your USB-to-Serial converter is working, and then suddenly stop, it seems it is usually after an update from Micro-Soft.

My recommendation is to keep each version of the Drivers that you Download, install the latest version of the Drivers, and if that does not solve the communication issues, revert to an older version. Sometimes that does not always work…

What you have to be aware of is that there are several companies that makes usb serial adapters, the most commonly used chipsets are:

Silicon Labs

Prolific is the cheapest but also the worst, the drivers/chipset are simply incompatible with many devices and operating systems, including 64-bit systems, (even Prolific themselves actually does provide a 64-bit driver), they are simply too cheap and unstable.
The best chipset/drivers are the FTDI. These are very solid and compatible with most devices and almost all operating systems both 32 and 64-bit. These usb usb to serial adapter are a bit more expensive but well worth the money.