User Program has exceeded time limit of 3 seconds (Robot Mesh Studio)


#1

Hello,

Computer Science teacher here.

I am programming VEX IQ robot brains (version 2.1.2 firmware) with the Robot Mesh Connect Chrome extension (Version 2.0.1.1) on Windows 10 computers. Students program using Blockly from that site.

In the last day, the simple programs that my students have been downloading have stopped executing. I am getting the error “User Program has exceeded time limit of 3 seconds.” When I reboot, the error continues to occur.

(When I say simple programs, the students have to calculate distance and program the robot to drive and bump a cup. They do set up the drivetrain correctly. It is basically a one-line block program.)

I have tried all sequences of removing and reinstalling the extension and the windows plugin. It appears that the website makes the connection to the robot brain, can download, and the program appears on the display of the robot brain. But each time the check mark is pressed, there is the delay, and then the error message is displayed.

Does anyone have any additional suggestions that I should try in my troubleshooting? Anyone have the fix? Again, everything worked fine yesterday, but not today. Lesson Plans kaput.

Sincerely,

Mark


#2

Hello again,

Everything works fine with the Desktop version of Robot Mesh Studio for windows.

Perhaps there is an issue with the Chrome Extension?

Mark


#3

Two things to try:
Make sure that you have the drivetrain set up properly if you are using one. (just noticed you mentioned that in your post but I’m leaving the recommendation here for others)
Also, if your program has a joystick configured, it must be turned on and connected for the program to execute properly.

I’m glad to hear from one person that RMS works fine for them. We’ve had quite a few problems, compounded by a lack of sufficient error messages. Things won’t work but we have no idea why without calling tech support. The good news is that Sam, who usually answers the phone, is very patient and able to work through most things.
They seem to be aware of most of the issues we call about, but for some reason they aren’t fixing them and there is no place to look online to see common errors and troubleshooting tips.

If you resolve the issue please post back and let us know the solution.

Ann


#4

We had a team with this error a few years ago. They were using ModKit. Their code had a lot of "Broadcast"s and the solution was to use less of them. I believe the processor has a limit to the number of separate processes it can handle. I suggest you save a copy of the program and systematically delete code until it doesn’t give you that error anymore.

Paul


#5

Hello again,

So I resolved the issue by going to Robot Mesh Studio Desktop (Windows version).

Now I am watching to see if the tech department takes away the desktop computers and gives me Chrome computers.

Sigh.

Mark