Using Higher voltage for a Vex Motor Controller

Hello,

I am trying to integrate vex parts into an old 4x4 rc truck. I am trying to figure out a way to control the motor that is mounted in the truck. I first tried to hook the motor up to a vex motor controller (desoldered the vex motor and attached leads to the truck motor). With the gearing and additional weight of the vex components the voltage supplied by the vex microcontroller is not enough for the motor.

I was wondering if anyone has tried to hook a power supply up directly to the motor controller board. Signal wire (White?) to the MicroController, and the orange (+?) and black (ground) wires hooked up to a power supply greater than the vex battery. I am not sure how much more power the controller could handle.

I don’t want to just start hooking up power supplies to the board, since I am worried about frying the Vex MicroController.

Any Help or ideas would be appreciated,

-Brando

The motor driver electronics can probably handle a higher voltage than the Vex battery. What is the voltage of the original 4X4 battery?

It is likely that you are running into a current limitation rather than a voltage limitation. The motor driver has a self-resetting fuse that shuts off the output if you exceed 1 Amp for any length of time. You might try bypassing that fuse. It is the part that is marked 7XL near the black wire in this picture.

Try Quazar’s, Secondary Motor Circuit. This will let the motor pull the MAX CURRENT of the Battery (or Wire).

Thanks for the Link MarkO. That is exactly what I am looking to do. So it looks like what I am thinking about has been tried before. What is the rectifier for? I am guessing that it is to prevent power from flowing back into the microcontroller?

ltk - the car ran off of 4 C batteries. I wonder how that compares to the microcontroller output voltage?

Thanks for the ideas:)

-Brando

C Batteries are 1.5 Volt for Zinc-Carbon (ZnC) and Alkaline, and 1.2 Volts for NiCd and NiMH.

4, C Batteries in Series would be 6 Volts or 4.8 Volts. The Vex Controller is connected to a 7.2 Volt Battery.

Historical Note: AAA, AA C and D are really Cells, the 9 Volt really is a Battery of 6, 1.5 Volt Cells in one case.

I also have revealed how old I am…

Right, If you just hooked all the red wires together, then power from the secondary battery would be fed back to the VEX Micro. The rectifier serves as a check valve to prevent back-powering the VEX Micro, but allow power to come from the VEX Microcontroller if you don’t have a secondary battery plugged in.

If you know you will always have a secondary battery, you can just omit the rectifier and tape-off the red wire coming from the controller.

Cheers,

  • Dean

okay,

It sounds like I was mistaken to assume that it is a lack of voltage causing the motor to run slow. I must be getting more current when I run it off of the 4 C “cells”:slight_smile: , because the car runs a lot faster.

Do any of you know how much the current output differs between the two power sources in question.

Thanks again,

-Brando

Lack of Voltage will cause it to run slower. It requires 1 Volt to push 1 Amp* through* 1 Ohm of resistance. So if the Voltage Drops, and the Resistance is the same, less Amperage is delivered, and the car moves slower.

Each Motor Output on the Vex Controller is limited to 1 Amp. 4 Amps TOTAL for ALL 8 Motor Outputs. Quazar’s little cable removes the 1 Amp limitation.

Actually, there is no 1A per-port limit. There is only an aggregate 4A limit for all the ports. This was discussed here and we got confirmation from John V-Neun.

Seems like a good time to whip out a voltmeter/ammeter and see what the motor draws normally -vs- being driven by the VEX.

Cheers,

  • Dean

Mea Culpa… :wink:

I was remembering the Original Specs I had read, and it seems the 1 Amp Limit is per the Vex Motor itself.

Yep - the original specs were not worded clearly and many people came to believe there was a per-port current limit.

The secondary battery circuit was really just to allow more motors/servos to run at full power simultaneously.

Cheers,

  • Dean

Hello Again,

I tried to connect the 4 C Batteries to the Motor Controller (+) to Orange and (-) To Black. The White wire is connected to the VEX micro. I then also connected the motor. The modifications do not work.

I also jumped the fuse that MarkO was talking about. This also did not help.

Any Ideas? The C Batteries must not be an adequate power source.

Regards,

-Brando

Since 4 C cells runs the motor under normal circumstances, it probably isn’t the power that is the issue. What happens if you attach the 4 C cells directly to the motor leads?

Perhaps there is something about the motor itself not happy with the PWM signal coming out of the VEX motor board. Unfortunately, without more detailed knowledge of the motor in question, I don’t know what we can do to help.

If you have access to a voltmeter, you could measure the voltage and current draw of the motor at full speed (being driven by the original electronics). That way you would at least know what it expects to be driven with.

Cheers,

  • Dean

Here is what I have tried so far:

I can run the motor in question by just hooking it up to the VEX Motor Controller. It runs too slow / weak.

I can run the motor directly off of the 4 C Batteries.

I am currently trying to use the VEX Motor Controller with the 4 C Batteries as the power supply. I hooked up the motor to the Motor connections. I bypassed the onboard fuse (in case this was causing the alternate power supply to not work). I desoldered the black and orange leads, and hooked up the 4 C Batteries (In Series) to the (+) and (-) inputs.

Attached is a diagram of the circuit.

Nothing happens when I try to activate the motor. I thought I might burnt / shorted the circuit board so I hooked it back up to the vex motor and it works fine.

All I can figure it that the output of the C batteries must not be regulated correctly for the motor controller board

Thanks again,

-brando
Diagram.jpg

You have to connect the black wire between the VEX Microcontroller, the motor controller board, and the - lead from the C cells. Without this ground reference, the white signal wire is as good as disconnected.

Other than that, it looks like you’ve got it wired correctly

Cheers,

  • Dean

Aha…

That makes sense, I will try it out tonight.

Just to be sure I updated the diagram. Does it look right?

Thanks for your help.

-Brando
Diagram.jpg

I keep replying to the wrong posts. This is the most convoluded thread ever… Good luck to anyone trying to make sense of this:rolleyes:

-brando

Yes, it should work now (or at least, it should do something)

I think one of the servers that hosts the forum has a bad time setting. If that happens to be the server that handles your post, then it gets a timestamp in the past, causing it to show up at the wrong place in the thread.

You can delete your post and re-post it and it usually gets it in the right place. Just make sure and copy your message text so you don’t have to re-type it when you repost.

[just happened to me - this is my 2nd attempt to post this]

Cheers,

  • Dean

Worked like a charm…

Thanks!!

-Brando

Glad to be of assistance (well, Quazar did most the work…).