Using Robot Mesh

I’m a first time user of Robot Mesh and I was able to write a program but I’m not succeeding in getting the robot to use the program.
Any help, documentation or other resources that might help would be greatly appreciated.
I installed 2 extra motors for a total of six and would like to use the extra motors to control a newly installed elevator.

To download a Robot Mesh program to the brain: [LIST=1]

  • First, ready your VEX IQ Brain by downloading and installing the most recent VEX IQ firmware from www.vexiq.com/firmware.
  • In order for your web-browser to connect to the Brain, you will need to download and install the Robot Mesh Connect plug-in from http://www.robotmesh.com/project/install. We currently support the latest Chrome, Firefox and Internet Explorer on Windows, Chrome on the Mac, Chrome on Linux and Chrome on the ChromeBook. Refresh http://www.robotmesh.com/project/install after installing the plug-in to verify it's installed correctly. [Note that there are two things to download and install for Chrome/Chromebook]
  • Make sure that your VEX IQ Brain is connected via the USB cable.
  • Look at the top where there is the **Port:** drop down. Choose the COM port to which the VEX IQ Brain is connected (e.g. **COM10 VEX USB**). If the port is not listed, click the **Refresh **button to refresh the devices listed in the drop down.
  • Now that the port is selected, click **Build** and the program will be saved, compiled and downloaded to the VEX IQ,
  • The program will then run immediately. It is also available in Slot 1 for running later. [/LIST] The steps above are the same whether your program is Python, Blockly or Joystick Wizard.

    Note that downloading a Python program to your VEX IQ brain will clear any program stored in slots 1 - 4.

    You’re welcome to ask specific programming questions here. Or in the Robot Mesh Python forum at http://www.robotmesh.com/forum/python-for-vex

    Thanks,
    Anthony

  • Thank you so much
    I’ll follow these steps and see if it works.

    So, I just went through this; not without bumps in the road. Using RobotMesh’s online python tool seems to be the quickest and most lightweight path to programming a VEX brain, but it is still hard to love the process. Most people will hopefully have an easier time getting this to work than I did, but I wanted to document my experience in case someone sees an obvious error in my ways, or has a similar experience.
    The biggest challenge appears to be to get the drivers to load properly. I am curious to why the brain does not work with an industry standard Prolific or (preferred) FTDI USB-serial driver. It is also not clear to me if the driver that VEX installs as part of the Firmware Updater and the one that RobotMesh installs as part of the Connect plugin are the same or potentially in conflict.
    I first tried to install on a Mac Pro with Yosemite. No luck, the driver seemed to install and load ok, but no device showed up when plugged in / switched on the brain. No errors (dmesg, kernel log). Neither VEX firmware updater or RobotMesh Chrome plugin detected a port. I checked the driver signing stuff and “allow software by anyone” settings, rebooted a few times: Nothing.

    I have a couple of Linux boxes around, but they’re Arch and Gentoo and so I did not try the Ubuntu packages.

    The Windows 7. Not to keep you in suspense… I got this to work, eventually. Hopefully I am the only running into these issues, but if not, here is what I did:

    • Installing the VEX Firmware Updater first got me a driverless “Base System Device” in my device manager. The installer completed without complaining, but Windows did say it was unable to install the drivers. Trying to update the drivers for that lead nowhere good.
    • I then tried to install the RobotMesh plugin, to see if that had a more palatable driver install for my system. Installation also succeeded, but no com port showed up.
    • removed the Base System Device, removed the VEX Firmware Updater and installed it again.
    • Surprise: In addition to the non working “Base System Device” I now had a Virtual COM Port, with a little yellow exclamation mark. Also, it was not called “VEX …” Neither the RobotMesh or VEX Software would see it.
    • Did some plugging and unplugging, turning things on and off, rebooting you name it. No change.
    • Used device manager to find the non-working COM port and hit “update driver”. Looking at Windows update (as usual) did not find anything, so I told it to look at: C:\Program Files (x86)\VEX\VEX IQ Firmware Update. No luck finding something there.
    • Then manually ran DriverInstaller.exe from that directory. Not sure what if anything that did, but the COM port did not work after that.
    • Now I had a directory called usb_driver under the above directory though. (Not entirely sure if that had been there before). I gave this to the driver update for the Virtual COM port.
    • Voila! It turned my undefined COM port into a VEX COM9. The Firmware Updater saw the connection.
    • I had a couple of things to update. I connected all the sensors and hit update all. This succeeded.
    • I then clicked through the Modkit, RobotC, Other and Smart Radio options, just to see. Smart Radio advertised a possible update for the brain to v1.16. I figured, why not?
    • I now ran the RobotMesh online tool. it saw the COM port, but connecting failed. I unfortunately did not copy the error message. “invalid something”
    • took a break to regain my calm.
    • went back to the Firmware Updater; could that still see it? Yes it could. It showed under RobotC that it would like to “upgrade” back to 1.15, instead of the 1.16 that the smart radio installed. I guess I do not fully understand the differences, nor what one should use if you want to use RobotMesh’s online tool. “Other” perhaps. Either way, I reinstalled the v1.15, downgrading from v1.16.
    • went back to RobotMesh, connected, and boom. success.


    Thanks for sharing your experience.

    On Windows, installing the VEX IQ Firmware Update Utility is the best way to install the USB device drivers for the VEX IQ. Follow the prompts at installation and make sure that the VEX IQ is unplugged when installing the VEX IQ Firmware Update Utility.

    We don’t currently support the Blockly/Python with the Smart Radio, and so recommend using firmware v1.15 at the present time.

    The Robot Mesh browser plug-in doesn’t install a USB device driver for VEX IQ, so there’s no conflict. We plan to do this as a feature request for a future release, so a single install will include both the USB device driver and the Browser plug-in.

    You just need to add a hopper and one hundred balls to your red/blue sorter for instant chaos.

    Best Regards, Anthony