V5 Autonomous Disconnect

Hey everyone,
We are trying to use a competition switch to run our autonomous program. However, the controller will disconnect during autonomous about 50% of the time. This causes the robot to do a variety of things like continue the autonomous after a pause, continue autonomous after the auton is disabled then enabled, and even continue autonomous after we restart the entire program. It only disconnects during autonomous on the competition switch. The controller does not disconnect otherwise. We are at a loss as to why it is doing this. It disconnects no matter what the battery level is.

To start everything off, are you making sure that the system is running the latest version of vexOS?

1 Like

Yes we have checked the brain and robot with VCS and the firmware utility. It is fully updated.

It has disconnected about 51 times according to the log in the firmware utility.

What is the name of your project?

If you’re on V5, why don’t you run the autonomous mode on the controller? You wouldn’t need the competition switch, it might work better. I don’t know. Is the wire connecting the radio to your brain damaged in any way? Is it in a good spot? I’m not completely sure of a solution.

PROS project titled 569A

Ok, not what I was thinking could be the problem.

I’m pretty sure the radio spot is fine. We were using a custom length cable but then we switched to a normal short cable and it didn’t change. The reason we didn’t use the autonomous mode on the controller was because we didn’t know that there was one. Also, we use an auton selector so I’m not sure how that would work.

Does it have the same problem in competition? The competition controller or port might be busted.

Yeah one of the options after you select the program on the controller is an autonomous run mode, never tried it with an auton selector though. It might be able to work, like select the program on the controller, it should say press A when ready. Before you press A the auton selector might be on the Brain and then select the auton and press A. It sounds like it works in theory but I have no clue.

If it doesn’t work like that, you could make a program with only a certain auton to test and allow you to test that singular program using the controller. That’s completely useless though if it still disconnects in competition. Good Luck on figuring it out.

In the competition autonomous run mode, the code will not show the auton selector.

I agree that we could do that but I don’t think it would help since it would probably still disconnect in competition. When we do a competition autonomous run, it hasn’t disconnected the couple times we tried it and we can test code. But the big issue is competition.

1 Like

Yeah, bad parts of V5. Maybe try to eliminate as much static getting to the brain and the radio. Does it disconnect at the same point in the auton every time? If you do anything super intensive in auton like running in to walls or something maybe remove it? If you have extra competition switches, brains, or radios try switching them out and see if anything changes. Bad luck of the draw when it came to V5 for you it seems.

It does not always disconnect at the same time. We don’t ram into any walls.

Send me your code (the .vex file) when you get a chance and I will have a look.

We are using PROS and for some reason the files won’t attach. The forum says that the files are not supported. We did the new 1.0.7 update and the disconnects are as bad as ever. The disconnects increase when we have a lower battery, but they still happen. We literally could not run auton today it was disconnecting so much.

Are you using bluetooth or vexnet ? Try using the other type of connection but I had a bad experience using bluetooth.

One thing that often happens when you push the robot really hard is the connection loses stability. Maybe try to let it breathe for a second (sometimes I’ve heard of teams putting their robot in the fridge) and after a little bit it should probably work more consistently.

I didn’t know there was a difference. How can I tell which I am using?

You can see on the controller itself where it shows the quality of the connection between controller and robot. If there is a V then it’s using vexnet or if there is a B then it’s using bluetooth. If want to change the type of connection then you need to change it on both controller settings and on the brain.

Also are you running the autonomous mode right after you download it? I have the same problem when I download wirelessly with pros where I had to wait till robot disconnects then run the auton. If I don’t then it would disconnect when the code is running and then mess up everything.