V5 Battery Issues

Our team just received two V5 batteries about month ago. One of them is working just fine but we’re having issues with the second one. After two weeks or so of getting the battery, every time we went to charge it, it simply didn’t. We’d plug it in and it would start charging but after 30 seconds, it started blinking red.

We’ve tried almost everything:
-Resetting the battery
-Charging it while it’s plugged in to the cortex
-Updating the battery to its newest version
-Switching chargers
The battery can still power the cortex but it’s starting to lose power and we’ll eventually need to charge it again. If someone has had this issue and was able to fix it or anyone who’d be able to help knows what to do it would be deeply appreciated to help us. Thank you.

Is the battery updated with the firmware in the latest vexos, V1.0.2 ?

Is the blinking red led fast (perhaps 4 blinks every second) or slow (1 blink per second) ?

Are you charging while connected to the V5 brain ?

Yes we updated the battery to V1.0.2 last week and it still blinking red.
And it’s blinking red led fast.

We tried charging it while it was connected to the brain and aslo while it wasn’t

ok, and when you plug in the charger do any of the green leds turn on ? Doesn’t the red led flashing happen immediately you plug in the charger or after some time ?

When we first plug it in, two green leds turn on but 30 seconds in, the red led blinks fast.

Ok, try leaving the battery on charge with the red flashing led for perhaps an hour. If the red led turns off, unplug the charger and then plug it in again, let me know what happens.

The fast red flashing led is indicating an error, probably because one the battery cells has become unbalanced (ie. one cell is charged when the others are not).

I plugged in the battery for about 2 hours. The red light is still blinking fast.

If this is an error, is it possible to fix it?

Ok, I will try and send you a special program to run tomorrow by private message so we can pull some information from the battery, but it sounds like it needs to be replaced.

I am having the same error. 4 teams with only four batteries (ordered 8 spares in June, still don’t have). With a competition in one week, we now don’t have enough batteries to compete.

Looking for help.


we were able to compete yesterday with two batteries (b/c we were able to borrow one). it certainly seems like we needed both. we had 5 matches in the morning with the longest time between matches as 30min. but the big one was 20min from out final match to the tournament. i suppose if you don’t plan on running skills or being on the practice field one battery might work but it would be a risk.

maybe you can ask local teams that are not competing next week if you can borrow batteries for the event.

Which error ? How many batteries have the error ?

1 battery is blinking red fast. Has been on the charger for hours and hasn’t cleared up. Have the latest firmware installed.

Keep using the battery.
the fast red blink indicates one cell has finished charging before the others, after a couple of discharge/charge cycles this usually clears up.

Where can I find an official test or evaluation procedure to deal with battery problems?

So is it conclusive that if you have a fast blinking light just to charge it for a long period of time to even out the cells? Also use it and just repeat that process to see if it clears?

If you get the fast red flashing led during charging towards the end of charge, the charge has been terminated due to one cell becoming full before the others.
Just use the battery normally, Ignore the capacity reading. Use the battery on the robot until the system shuts off. Charge the battery again, usually after a couple of full discharge/charge cycles it will clear itself. Do not use the reset button ! Using the reset button just confuses the battery further.

Now in the middle of our team practicing the battery started blinking red quickly and the controller was disconnected. Before this the battery had been reading around 40%. The battery only charges to 85%, though were seeing that increase about 1% each time we ran it all the way down and charged it back up. We have a competition tomorrow and this team has worked their tails off to get ready. We ordered two 6 spare batteries in June that we still don’t have. I called vex support about our issues on monday, expecting them to quickly ship a replacement, but was told to update firmware (which I had already done). They said if I updated firmware via the standalone updater it was different than with VCS. It wasn’t. I’ve been given all sort of things to try. I also have two motors that have stopped working. I will be calling sales to get those replaced on Monday, but it took a VERY long time to get one of those brand new motors off of our RD4B and replaced (thank goodness we had replacements).

I’m preparing myself to console this team when they lose a best of one series because of a battery malfunction or random motor issue. Seriously regretting the switch.

We might be able to lend you a battery. but you would need to drive down to seymour tonight.


We can lend you a V5 battery at the KIDS inc event. Come see me at the 6210 pits.