V5 Battery lights conundrum

Last night, our sixth grade team had recurring issues with their V5 batteries. 3 different batteries fully charged quickly developed issues showing the single red light. Off the robot, the battery then displayed two green, a space and then one red light. And once they pressed the reset button, the battery showed four green lights. Any ideas?

Looks like they had a glitch, and the reset button fixed it.

1 Like

Use the v5 battery medic to see if anything is amiss:

1 Like

Taran and Sazrocks–Thanks. We were planning on running Battery Medic tonight and going from there. And we are going to put a masking tape log on the back of each battery to track any new status updates on the lights as just color is not enough to diagnose,

This article is really useful as well, so you can decipher error meanings: https://help.vex.com/article/142-how-to-interpret-error-messages-with-the-v5-battery
I would suggest looking at step 3 and step 5.
Do what @sazrocks said about running the battery medic as well to confirm if step 3 is the problem, and if not it likely is step 5, in which there’s a firmware error.

1 Like

were the leds flashing ?
Do you mean you pressed the button on the battery or the hidden reset button ?

I do not recall. But I accessed the docs https://help.vex.com/article/142-how-to-interpret-error-messages-with-the-v5-battery and will have them log the statuses tonight. They are also going to run through the Battery Medic steps as well.

@jpearman We pressed the hidden reset button.

try to avoid that unless the battery won’t charge or respond in any other way.

@jpearman We will do. It is not something we’ve done before

We have this issue with v5 batteries as well (4/6 batteries we own have this).

@DRow recommended to charge the batteries for a bit while connected to a brain, this worked for some of our batteries. (others had to be RMAed)

Updated firmware appears to have resolved the issues.

1 Like

That’s odd, what firmware were you running ?
The last time we updated battery firmware was V1.0.4 back in December.

@jpearman Honestly, idk. Eight years in Vex and I have no idea about programming. My job is primarily logistics. I though am always on them to update firmware but since I don’t do programming I cannot say what.

Last night was a multi-faceted approach while I usually like doing one thing at a time to isolate and understand the problem. But with one week, i wanted them to just find a solution more. The first thing was redoing firmware. We also took to plugging the battery up while on the brain as suggested by @Nerdom. There had also been a prompt on the brain to do that. The batteries afterwards did not drain fast, no light codes were recognized nor repeated.

In the end, i thanked the forum and facebook because I feared dead cells on multiple batteries though while I did recall the red and green lights I did not have any specific recollection of any flashing of either the red or green lights which was diagnostic of both bad cells and firmware.

I do know that this particular team did not do any programming until after the December release. And there is a good chance that for this team it was one battery three times and not three separate batteries because this team did not get its third battery until just a few weeks ago. So, I may find out more after Worlds simply because I am pretty good at cross-examination but with only a week left before Worlds I am not inclined to press for answers.

If the brain prompted you update battery firmware, and plug the charger in so it could do that, then it does sound like you were on pre V1.0.4 firmware. There is a list of firmware releases here with the more important release notes.

The most critical battery update was the first one in October, that fixed most of the problems encountered at release. The November and December releases continued to improve battery stability and adjust some of the thresholds we use to shutdown the robot when the battery is low, it also changed the status indication on the leds to help tech support debug battery problems.

If you have any concerns, bring the batteries over to tech support next week and we can take a look.

Glad it wasn’t anything more than a firmware problem, you got the good end of the stick right there sir :wink: For me, I got the bad end of the stick: a battery with a broken cell. But VEX was incredibly generous and sent me a new battery
I’m glad I could help :slight_smile: