V5 battery not charging


#1

In short, we have a 1-2 month old V5 battery that will not charge. When the power button was pressed, nothing happened. We thought the battery might have been completely flat, as it had sat unused and unplugged for the entirety of winter break, but after ~30 minutes of being plugged in, nothing had changed. The charging cable itself works, as we tested it using another V5 battery, which immediately started charging. At that point, we used a paperclip to press the reset button, and a quickly flashing red light lit up only one of the four power level lights. Nothing has happened since then, is there a way to fix this, and if so, how?


#2

Have you tried charging the battery since you pressed the reset button?


#3

Yes, we plugged it in and only one of the power level lights turned on, meaning it was probably close to being flat. We left it plugged in for a couple hours, and when we checked it, the light was off and nothing worked again.


#4

First, make sure that your V5 brain has the latest firmware update (1.05). If not, update it and power cycle it. (Turn it off , wait 10 second or so, then turn it back on). Then, connect the battery to the charger and the brain. The brain should give you the option of updating the battery firmware. This will give the battery much better performance and, hopefully, it will charge. If your brain needed updating, you should also connect your radio and your controller to is as well and update all of them.


#5

Thank you!


#6

You are welcome