V5 battery problems

Hey, everyone! Our v5 batteries don’t turn on. We tried resetting it with a paper clip. However, it still doesn’t turn. Is there any other way to fix this?

Were they updated to the latest firmware ?

Yeah i am having the same problem. I have tried 2 batteries now and i am getting extremely frustrated. I have tried updating the firmware and I have successfully sent the new firmware over to the batteries and i have also been experiencing issues. I have plugged the battery in independently, while connected to the brain, pressed the reset switch. I have tried everything. It could be user error but every time I charge it, after like 3 minutes it just starts flashing red rapidly. I find it hard to believe that both of these batteries are bad and so far I have been extremely dis-satisfied with the v5 system and the support available from vex.

See the other thread, just use the battery normally on the robot, see if it clears up after a couple of full discharge/charge cycles.