V5 Battery

My V5 battery died, and I went to recharge it, but it won’t charge. The indicator lights don’t turn on, and the Brain doesn’t turn on when the battery is plugged in. My robot has worked for the past two days just fine. Has anyone had a similar problem/know a solution?

I’ve seen a couple instances of this. Most of the time, if you try to charge the battery while it’s still connected to the V5 Robot Brain, it will start charging again. If for whatever reason this doesn’t work, send me a PM. And we can look further into it.

1 Like

Hello again! For anyone who has had or has this problem in the future, the solution is to find some thin stick and put it in the hole on the front of the battery (I used mechanical pencil lead). I think this is a reset button of some sort as the indicator lights flashed when I pressed the button. I’ll include a picture of where the hole is for anyone who can’t find it.
Screenshot 2018-09-14 at 12.07.58 PM.png

Oh, haha sorry, I think I posted just after you did. I didn’t think to try the Brain thing, but right now my battery is charging so thank you!

We are having the same issue listed above. We have tried reseting the battery thru the small hole with a paper clip, we have tried charging it while connected to the brain, we have also tried pressing the reset button while connected to the brain. Nothing is working. Any other ideas?

Team 77000X

Yes, I have had my battery die as well. Have tried all the obvious steps.

Same here with our battery. We’ve tried all of the above steps too. Has anyone talked with VEX support. Will they send replacement?

When we first got our V5 bundles, we plugged one battery in to charge over the weekend. We came in on Monday and it was dead. I called VEX and they told me to reset it. Tried the reset button still dead. I had bigger fish to fry, so I just left it alone for a few days. My guess is that it was over charged and after some time to discharge, it magically started to recharge and it has been fine ever since.

Same problem. When I got my bundles, two of the batteries wouldn’t charge. The other 4 worked fine for a week. I charged over the weekend and now none of them work. I’m frustrated and so are the kids. I have no power. Has anyone heard from tech support? What is the fix?

I had the same issue, but I was able to solve it. I first used a paperclip to click the battery reset button. What I then did was plug the battery into the v5 Brain and have it simultaneously charge. After about a couple hours of charge (I personally left it overnight but I assume that it charged in maybe 2 or so hours), it worked.

Does anyone know what the reset button is supposed to do? I was pressing it today, nothing was happening, and I was wondering if I should even be pushing it in this case.

The other battery I have worked. I left them together tonight to talk it out. Hopefully, in the morning all will be well. I don’t have any motors yet, so it isn’t totally important at the moment.

I have no definitive evidence (I don’t even have access to a V5 battery), but I would guess it resets a microcontroller (and, thus, its software) that controllers the battery management system.

I hope the recurring battery issues are merely the result of bugs in the BMS software, because a software fix would be quite easy to implement at the factory.

We’ve had the same V5 battery issues. Yesterday was the first time the reset button did not work. I had tried all of the combinations of reset, connect to brain while charging, etc but still could not get battery to charge. I left the battery unplugged overnight and then came in this morning, plugged battery into charger (not connected to brain) and it’s charging.

I really hope all these battery issues are just a case of bugs in the firmware.

If not, this could get ugly.

I am not exactly a fan of my battery needing a firmware update. That sounds like a recipe for disaster.

It is a recipe for disaster. Leave it to an important match or right in the middle of a tournament where you have firmware issues in your battery.

In general I prefer the simple approach for things that I need to work 100% of the time. With that said my Mavic Pro’s “smart Batteries” are pretty nice and are controlled with their own software. They are absolutely a component on the aircraft that needs to work 100% of the time, so this tech can be done reliably.

Is there any documentation for updating V5 battery firmware?

I sincerely doubt VEX would even consider releasing documentation for updating battery firmware, let alone encouraging people to do it.

First of all, the batteries can hold a lot of energy. If you don’t know what you’re doing, you might end up with a shock, explosion, or worse.

Secondly, I’m sure the batteries were not made to be serviceable (even though they may actually be fairly serviceable), and updating the firmware would probably require desoldering and a special programmer.

If any of you are commenting based on my post, do note that I said at the factory, not by end users.

Or, crazy though it may be, you might just pop a battery into the V5 system, plug the V5 system into a computer, launch a VEX program on the computer and push a button to download the most up to date firmware. Minimal shocks, explosions, or LD&D payouts.

well my DJI batteries allow for firmware updates. It checks in pre-flight.

I am not proposing that i let my 15 year olds custom code it, simply do it like any other tech company and let the app identify out of date software and then push the update.

They’ll need some apparatus for this, especially if they are shipping us bricks.