V5 Brain is not being recognized by the computer

I cannot for the life of me get my brand new classroom lab to recognize the V5 brain for programming. I have both of the latest versions of VEXcode blocks and text installed. I’ve tried to uninstall and then reinstall both programs. I’ve tried restarting the computer. I’ve tried going to C:\Program Files (x86)\VEX Robotics\Drivers and running the “Console Driver Installer.exe” as an admin.

The only thing I could think of to get the everything working was to install VEX Coding Studio. This solution worked but do i really need to install VCS on all 17 computers in my lab? Seems silly. Is their another approach to this?

Thanks in advance.

I believe that is an issue with V5 drivers, I have the same problem. As of right now, Coding Studio is the only solution I have found. There is a folder in the Coding Studio files named “V5 Drivers”, look for that and I believe you only need to transfer that individual folder rather than the full program again.

I personally found that the fastest way was to download Coding Studio on my personal laptop, get a flashdrive, and transfer ONLY the V5 Driver folder. Then, transfer that folder to the same folder as VEXcode on the receiving computer.

Hopefully this works, let me know if it does because I’m trying to find a more permanent solution myself.

Thanks, I may give that a try. I’ll let you know.

But try not to use Vex coding studio, it’s outdated and has been discontinued by Vex.

Do you use the same cable across all 17 computers? (I mean the USB cable that connects the v5 brain to the computer)
It could be that the USB cable is slightly damaged, making the computer not recognize the brain. I had this issue too and was pretty baffled by it, until I put a new cable in.

I don’t think the cable is the issue. I tried it on a laptop(which had VCS installed from last year) and it worked. I Decided to install VCS on my teacher computer. The brain then connected to my teacher computer.

1 Like

Maybe there is something wrong with the computer, the USB port may not be working.

I am having this same issue. My students have tried various combinations of cords, brains, and laptops. They are unable to get the brain to connect to any. I don’t know where to find VEX Coding Studio anymore. When I search for it I get broken webpages. Has anyone else figured out another solution?

Vex Coding Studio has been discontinued by VEX. Try using VEXCode, the new software by VEX.

I understand that, if you follow the entire thread someone suggested downloading VEX Coding Studio to get a file from the download. They said that helped them, however, I cannot get the download. I am asking where they got it, or if someone else found a better option.

Here’s the download, for Vexcode:

VCS should not be needed.

Go to the device manager and, with the V5 brain plugged into the USB port of the computer, check that the ports are showing up. You should see two VEX V5 COM ports as below.

device_man_1

You could also check the correct driver is running if they are.
device_man_2

post back in this topic with any results from this test.

1 Like

Thank you for the suggestion, I checked and both show up in the ports and both say the same driver version that yours does. However the brain is still not showing up on VEXcode. Also I plugged the controller in and that made the controller icon light up orange.

I am having the same problem, the computer recognizes the brain being plugged in, but Vex Block, does not see the brain.

Exactly! I got a response from VEX below. Unfortunately it takes way too long for my IT department to install software so who knows how long it will be until I can even test this out.

"Thank you for your email, I will be happy to help you.
Lets start by scanning your brains with VEXos, found here:


75bfae01770fffc2fb22e9bc71855119.png
Let me know your results please.
PS- Make sure VEXcode is closed, before you run VEXos. Else they will interfere. "

I have been trying for a few weeks to get our laptops to work with V5. VCS and RobotC worked, but VCText and VCBlocks are useless.

Current situation: Student logins allow the V5 Brain to be read but not downloaded to.

Our district limits student login rights, and they are unable to install anything or access the command prompt. After getting the software and drivers installed on our student computers, students’ limited-rights logins allow both programs to open and view information about a connected brain, but cannot download to it, prompting a generic error like “unable to download” in VCB and an issue with the command prompt in VCT. However when the same computer is logged in with a teacher-equivalent login, everything works just fine.

They have tried “running as administrator” and putting in an admin login, but it did not work either. Additionally, IT said they will not grant access to the command prompt (an issue that came up using vexcode text). What do we need to do to download code to the robots using logins with limited rights? Has anyone else experienced installing VexCode on enterprise systems with student logins?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.