V5 Brain not connecting to computer

I am using vexcode pro v5 and I cannot get the brain to connect. I have tried all the ports on my computer, multiple different cables, reinstalled vexcode and the drivers, but it won’t detect it. I also tried plugging it into the controller, but it did not detect that either. Any suggestions?

So I just held the brain up while the usb was connected to the controller and it just worked. I have no idea what caused this or why it happened, but I was able to download through the controller.

So not quite a solution - but one step in problem solving. Given the communication started working when you lifted up your V5 Brain - I suspect the problem may be with USB port on the brain. What is puzzling is you say the computer would not see the V5 Controller as well.


I think it might have something to do with the table I was using. I am now at home and tried it here and it works normally without having to do anything weird. Not sure what about the table/work area might have caused this though.

Interesting - I would not have thought that route. If it is the table - what material is it made of? is there a huge electromagnetic devices operating from it? Interesting.

At a place I worked a long time ago, people were mystified when they would visit the hardware lab (small space) their credit cards would die… It turns out that they used a big magnet to de-gauss CRT monitors - when not using the magnet, the tech was stick on the door frame for storage - so when people dropped by, they would be chatting while resting on the door frame.

So this mystery of V5 gear not connecting to computer while on a table is an interesting one!


Jokes aside – have you verified that your USB cables work by using them to connect to other micro-USB devices (or better yet, another V5 brain or controller)?

I’ve seen micro-USB ports go bad (not on VEX gear but on other devices) in such a way that the connection only worked if I pushed on the connector in a certain direction – maybe when you set the stuff up at home you happened to apply pressure to the cable in just the right way?


It’s just a wooden table and there are some magnetic screwdrivers and things, but I don’t think those would be strong enough to cause this. It is definitely very interesting.

That’s what I thought at first, but I just tried plugging the cable into my headphones and it immediately started charging. I did not have to apply any pressure or put it in at a weird angle. I do not have another brain with me at the moment, but I will try one when I get a chance.