V5 Brain to Macbook M1 connection issue

Can not get V5 brain to connect to M1 Macbook Air. It only has USB-C connections. Currently trying a USB-C to A cord with a USB-A to micro USB dongle. We used the dongles with the last Macbook air so we didn’t wear out the micro USB connection on the brain. They worked fine last year so I doubt the cords. Want to know if it is a VEX or Mac software issue.

Hey @HackAttack

I’m from the VEXcode dev team. We’ll look in to this on our side with some M1 machines. In the meantime, you can try a couple things.

Firs, you can try the VEXos firmware utility for the V5. If the brain shows up on that it probably isn’t an issue with the Mac itself.

After that, you can try restarting the app, then restarting the computer, and then if neither of those work, try reinstalling after making sure you’ve uninstalled/deleted the app. It could have been a bad install.

Thanks

Tyler

1 Like

FWIW my M1 air has had no trouble connecting to any VEX gear.

2 Likes

OK I tried all you suggested. None of them worked. The only way I could get it to connect was to use a hub on the laptop then run the USB through the hub.

1 Like