V5 controller don't respond to the programming

HI I NEED HELP WITH MY v5 controller, it don’t respond to the programming AND THE OTHERS DO IT

Please be more specific.

Is your controller paired with the brain? Does the brain says that the controller is connected? Is the radio working/plugged in? And what do you mean “the others do it”?

Also chill out with the caps lock.

1 Like

Also, if you think there is something wrong with your code, please upload a screenshot of it in a reply (assuming you’re programming in V5 Blocks) or the .v5blocks file so we can better help you with it.

Yes the controller is paired

Whit the “others” means that the other controllers that I have

Correct me if I’m wrong, but that is working fine. It shouldn’t be displaying things… also, 8 motors is max.

What does this code do now, and how is that different from what you want it to do?

Also, 2 side notes:

  1. VEX Coding Studio has been deprecated - you should upgrade to VEXCode V5 Text. It uses the same API and will easily import your existing VCS projects.
  2. I suggested uploading a screenshot because you tagged the thread as #edr-technical-support:vexcode-v5-blocks-tech-support. When posting text code you can simply copy and paste it into a reply, then highlight it and click the “</>” button to get it nicely formatted (or wrap it in [code]…[/code] tags manually).

Tower UserControl 1.1.vex (10 KB)

this is the code, i think that the problem is the controller because the code runs with another controller

If you have tried the same code on the same brain with a different controller, and it behaved as expected, then that would indeed suggest that your code is not the problem.

Others here can provide more specific advice in the area of controller-to-brain communications – I’m not an expert in that area.

1 Like

use the controller dashboard to verify the controller is working.



This appear in the screen of the brain

were you pressing buttons and moving the joysticks ? That shows L1, L2, R1 and R2 were all pressed.

Yes I’m pressing those buttons

well that implies the controller is working if you can see the buttons being pressed and joystick changing in the dashboard. I tried your code and it works here (it has other issues, but that’s a secondary problem).

Is the brain fully updated with latest firmware (1.0.8, look at brain dashboard) ?

1 Like