V5 Controller Flashing Red; Weird Battery Issues

My team’s fairly new V5 controller has started flashing the screen red every few seconds. Also, the battery symbol no longer appears charging when it’s plugged in. When we look at the battery capacity of the controller via the V5 brain, it appears to oscillate between 0% and 50% to random values multiple times each second. We have already tried resetting the controller with the button on the back.

I saw a team with this same issue this weekend. We plugged a USB battery pack into their controller and them remedied the problem for the moment. The team never returned with any further issues.

1 Like

Just as a note, there is a reset button on the back of the controller. It’s in one of the many holes in the back. If you press it, it turns the controller off and resets it completely. Maybe try doing that and see what happens. We had a similar problem and resetting worked for us.

Doesn’t this violate R14biii?

I had the same thought last week until I was shown the following Q&A.

https://www.robotevents.com/VRC/2018-2019/QA/42

1 Like

Did you make the USB battery pack part of your field kit? or did the team provide it?

I loaned the team my personal one and suggested they find their own when they got back to their pit.

2 Likes

Wow, that’s awesome! Where was this?

At the Toronto VRC Qualifying Event: https://www.robotevents.com/robot-competitions/vex-robotics-competition/RE-VRC-18-6682.html

1 Like

this is one of the many many many many many many many many many many reasons i don’t trust V5