V5 Controller Uploading on Linux

I’m having trouble detecting the V5 Controller on Linux, and I was wondering if there is a driver for it. I want to be able to upload programs from the controller to the brain with PROS, but neither prosv5 lsusb nor lsusb detects the controller. Any ideas?

It should be a simple USB serial device that does not require any additional drivers.

Have you tried a different cable?
Have you tried a different USB port?
Have you tried on a different computer?
Have you tried on a different computer running Linux?
Have you tried in Windows on the same computer?


I have tried several cables, and the controller can charge off the same cable that I can’t upload with.
I have tried both of my USB ports.
When I ran windows on my computer before, I could upload via controller with VEXCode Pro.
Unfortunately I have one computer, so if anyone else has Linux, let me know if it works for you!

Being able to charge doesn’t mean the cable can transmit data properly.

I was more asking to see if your cable and controller were recognized properly with a different OS or different computer. I am pretty sure someone I know successfully uses wireless uploading on Linux Mint.

What distro are you using?

1 Like

Btw, I’m able to upload to the brain with that cable; not sure if that helps.

Yes, that means your cable is not the issue.

Maybe try a simple Ubuntu or Linux Mint live environment — see if you can get the controller to be recognized by lsusb and prosv5 lsusb.

I haven’t ruled out the possibility that the USB port on your controller is broken either.

What version of the PROS CLI are you using?

I’m using v3.1.4, and I’ll see if Ubuntu works, thanks!

Update: It was the controller itself. I traded with another team who doesn’t need wireless uploading, and the new controller works great, but it sucks that we would have had to buy a new controller to get it to work.

Use one of those magnetic micro-USB cables. It will save your ports from wearing out.